1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Problem with Webalizer

Discussion in 'Plesk for Linux - 8.x and Older' started by rspurlock, Nov 28, 2005.

  1. rspurlock

    rspurlock Guest

    0
     
    Hi All,

    We have a very strange problem with webalizer. We have a server that only has 2 domains on it for a dedicated customer but the webalizer stats will not show up anything on the page. When we go to https://www.domain.com/plesk-stat/webstat/ to view the stats, it just shows "The page cannot be displayed". I've checked the settings in the conf files with the other servers and they all *look* fine. But no matter what, the page will not display.

    FYI we're running Plesk on CentOS 3.3 with the usual flavors and Plesk 7.5.3 with webalizer 2.01_10-15.ent.

    Has anyone run into this kind of problem?

    Any suggestions welcome.

    TIA

    Rob
     
  2. rspurlock

    rspurlock Guest

    0
     
  3. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Just to cover the basics, in the domain hosting setup, you did put a checkmark in the second box for password protected access to the stats, right?

    And have you also tried browsing to the non-SSL URL just to test ? If it comes up on http: then try resetting the option for password protected access (uncheckmark, save, recheckmark, save)

    The only other thing I can think of is to check ownership on the index.html file in:
    Code:
    # ll /home/httpd/vhosts/example.com/statistics/webstat/index.html
    -rwxr-xr-x    1 root     psaserv      4845 Dec  2 04:07    index.html
    You may have to use /var/www/vhosts/... or wherever the domainroot is on your server setup.
     
  4. rspurlock

    rspurlock Guest

    0
     
    nevermind

    Well... Thanks for your input. Apparently my last ditch effort to remove all of it, remove SSL capabilities of the site, and set webalizer back up worked. Since I removed the SSL option for the site, now it all works fine in a non-ssl url.

    Thanks again for trying!

    Rob
     
  5. cmurphy@

    cmurphy@ Guest

    0
     
    webalyzer problems

    So were having this issue.

    Running Plesk 7.5.4 on Fedora Core

    1. When we log into plesk, click our domain, then click "Reports", were getting a blank page.

    2. when going to our URL/plesk-stat were getting page not found. Which is correct since there are no files on the server in that directory. However, this is not supposed to be whats happening.

    Why are the files in /statistics/webstat not being linked to from /plesk-stat?

    Also, most of the files in /statistics/webstat/ are chown'd to root.root instead of root.psaserv, is this correct?

    Any ideas?
     
  6. jamesyeeoc

    jamesyeeoc Guest

    0
     
    The only file which needs to have GID psaserv is the index.html file:
    So that it can be served up by apache.

    The other files normally are all root/root.

    Plesk uses an "Alias" entry in the domain's httpd.include file to link to the domainroot/statistics/ directory:

    There are a number of aliases which should be within the <VirtualHost xx.yy.zz.aa:443> section:
     
  7. cmurphy@

    cmurphy@ Guest

    0
     
    you are correct, but there is a problem.

    Your example says that:

    alias /plesk-stat /home/httpd/vhosts/hyperacvtivehosting.com/statistics

    and there are no files on our system in that directory.

    The actual webalizer files are in:

    /home/httpd/vhosts/hyperactivehosting.com/statistics/webstat

    So isnt the alias variable being inserted into httpd.include incorrect?

    Because our httpd.include appears correct as:

    </IfModule>
    ScriptAlias /cgi-bin/ /home/httpd/vhosts/hyperactivehosting.com/cgi-bin/
    Alias /plesk-stat /home/httpd/vhosts/hyperactivehosting.com/statistics/
    Alias /webstat /home/httpd/vhosts/hyperactivehosting.com/statistics/webstat
    Alias /webstat-ssl /home/httpd/vhosts/hyperactivehosting.com/statistics/webstat-ssl
    Alias /ftpstat /home/httpd/vhosts/hyperactivehosting.com/statistics/ftpstat
    Alias /anon_ftpstat /home/httpd/vhosts/hyperactivehosting.com/statistics/anon_ftpstat
     
  8. buddaaa

    buddaaa Guest

    0
     
    hi,

    the source of the confusion is probably the wrong text: "(accessible via password protected directory '/plesk-stat/)" because that doesnt work, it's /webstat.

    that's wrong in english and german. a german only-bug is the translation of

    "Client cannot allow or disallow shell access"

    into

    "Kunde kann Shell-Zugriff erlauben oder verbieten"

    which means

    "Client CAN allow or disallow shell access"

    ... which made me think plesk really sucks since i couldn't find a way to disable shell-access ;)
     
Loading...