1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Problems copying table with phpMyAdmin

Discussion in 'Plesk for Linux - 8.x and Older' started by BigScreen, Mar 19, 2008.

  1. BigScreen

    BigScreen Guest

    0
     
    I am encountering a problem when trying to copy a table using phpMyAdmin.

    The error message reads:

    #1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '8322882DEFAULT CHARSET =

    The offending part of the command is:

    ) ENGINE = MYISAM AUTO_INCREMENT = 8322882DEFAULT CHARSET = utf8

    There is no space between the AUTO_INCREMENT value and the "DEFAULT CHARSET" parameter. This is without the "Add AUTO_INCREMENT value" checkbox checked. If I check it and re-run the operation, it just adds the "AUTO_INCREMENT =8322882" text onto the end of the command, basically repeating the text before it that is causing the problem.

    This appears to be the same problem reported here:
    http://forum.swsoft.com/showthread.php?t=40819

    I upgraded to Plesk 8.3 in the hopes that this would be fixed, but it was not. The above error report was submitted 13 months ago for Plesk 8.1, so it's surprising that it wasn't fixed since that time.

    My installation is Plesk 8.3 for Linux, phpMyAdmin 2.8.2.4 (current stable release is 2.11.5), PHP 5.2.5, and MySQL 5.0.51a.

    This error makes it very difficult to make test copies of tables for development or backup snapshots of tables. I am doing a workaround by copying the table manually with an SQL command, but that's not the point of having a web-based package like phpMyAdmin in the first place.

    Any information about the status of this problem would be greatly appreciated!
     
  2. j_kev@

    j_kev@ Guest

    0
     
    Please try upgrade phpmyadmin it is located here. just copied files
    /usr/local/psa/admin/htdocs/domains/databases/phpMyAdmin/

    But before create backup file of phpMyAdmin
     
Loading...