1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

problems installing ssl cert for control panel

Discussion in 'Plesk for Linux - 8.x and Older' started by tiretz, Jan 27, 2009.

  1. tiretz

    tiretz New Pleskian

    22
    23%
    Joined:
    Dec 9, 2008
    Messages:
    7
    Likes Received:
    0
    Hi All,

    I have installed a new SSl cert for my control panels domain into Server->Certificates. I selected it and clicked on "Secure Control Panel". Plesk said it was reloading the cert and eventually came back.

    I am aware from previous ssl installation (on standard domains) that I have to restart the httpd service.

    I did this and also restarted the psa service (service stop psa and start psa) from a shell.

    I still cannot get the control panel (port 8443) to pick up the new certificate.

    When I list the Certificates (server->Certificates) It shows the new cert as not being used.

    Any suggestions?


    regards

    Justin.
     
  2. Amin Taheri

    Amin Taheri Golden Pleskian Plesk Certified Professional

    33
     
    Joined:
    Jul 5, 2007
    Messages:
    1,398
    Likes Received:
    1
    Location:
    Seattle Area
    After installing the cert, you would click on the "make default" and then "secure control panel"
    Afterwards do this
    service psa stopall
    service psa startall

    then make sure httpd is running
    service httpd status

    then start plesk
    service psa start

    you may also need to clear your temporary internet files as it is possible you have it cached, even though ssl content shouldnt be cached. If you have a different browser (like firefox or chrome) try using that the second time.
     
  3. tiretz

    tiretz New Pleskian

    22
    23%
    Joined:
    Dec 9, 2008
    Messages:
    7
    Likes Received:
    0
    hello,

    I tried the steps you mentioned and still no luck.

    When I list the certificates it still shows the new certificate as being used 0 times. The initial self signed cert has been used 6 times.

    Is there a place in psa directories where I can check which cert it is using. Or possible manually change it?

    regards

    Justin.
     
  4. Amin Taheri

    Amin Taheri Golden Pleskian Plesk Certified Professional

    33
     
    Joined:
    Jul 5, 2007
    Messages:
    1,398
    Likes Received:
    1
    Location:
    Seattle Area
    Did you click the checkbox next to the cert and then click make default ?
     
  5. tiretz

    tiretz New Pleskian

    22
    23%
    Joined:
    Dec 9, 2008
    Messages:
    7
    Likes Received:
    0
    yes, that certificate is default and now shown as bold.

    i have attached a screen shot.


    regards

    Justin.
     

    Attached Files:

  6. tiretz

    tiretz New Pleskian

    22
    23%
    Joined:
    Dec 9, 2008
    Messages:
    7
    Likes Received:
    0
    I found a file called /usr/local/psa/admin/confhttpsd.conf file and found the certificate files it mentions.

    using

    openssl x509 -noout -text -in httpsd.pem
    openssl x509 -noout -text -in rootchain.pem

    I could see that the certificates were actually the new ones.

    i had a friend who had never been to the site go there and he got the self signed certs as well.
     
  7. chris_cross

    chris_cross New Pleskian

    22
    73%
    Joined:
    Mar 4, 2007
    Messages:
    15
    Likes Received:
    0
    Hi folks,

    got a similar problem.

    I´ve set up a new SSL for a seperate IP adress. I want to secure the webmail.<ourservice-domain> as well as the contol panel with SSL.
    I did both steps as mentioned above (set default and secure cp).

    When I open my browser, i get the message: hostname mismach.

    I´ve set up the hostname in plesk to www.<domain>. /etc/hosts contains the new IP and the domain name.

    Any Idea?

    Thanks in advance

    Chris
     
  8. getnetworks

    getnetworks Guest

    0
     
    Confirmed.

    On instances where we had upgraded 8.4 to 8.6, there is no problem, but fresh 8.6 installs are having this issue. We're a gold partner and are opening a support ticket. We'll let you know what comes of it.
     
  9. getnetworks

    getnetworks Guest

    0
     
    Also, as an FYI, you do not need to make the cert default in order to secure the control panel as has been mentioned. Those are two dinstinctly different things. One secures the control panel and the other is used as a default cert for anyone that enables SSL on their site but does not install/have installed a cert of their own.


    As for this issue, it appears to be related to build 86080930.03 as we do not see the issue on build 86080722.00. A ticket/bug report has been logged and we will let those impacted know of any resolution once we have it. We have let Parallels know that others are experiencing the issue (and have pointed them to this thread).
     
  10. AndrewK

    AndrewK Guest

    0
     
    I have the same problem

    I am currently unable to successfully assign a new SSL certificate to the control panel. I select the SSL certificate I want and then select the link "Secure control panel" and it redirects the page but nothing happens after it is complete. I have tried rebooting the plesk panel and the server itself and the certificate still does not load. My plesk build is 86080930.08

    I believe I am having the same problem tiretz is having. According to the other post it sounds like Parallels is working on it but I just want everyone to know I am having the same issue.
     
Loading...