1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Problems updating the gdlib

Discussion in 'Plesk for Linux - 8.x and Older' started by akany, Nov 24, 2005.

  1. akany

    akany Guest

    0
     
    I tried to update the gdlib on my server from version 2.0.15 to 2.0.32. I downloaded the rpm and installed it (rpm said the install was successfull and also yast says, that version 2.0.32 is installed now).
    But when i look into my PHPINFO it say that still version "GD Version bundled (2.0.15 compatible) " is installed?
    Do I need to do anything else to get it running? Thanks for any help ...
     
  2. ShadowMan@

    ShadowMan@ Guest

    0
     
    I believe that "GD Version bundled" means that gd was compiled into php itself, so you may have to upgrade your php to a version with a newer 'bundled' gd in it.

    In your phpinfo(), near the top, look in the 'configure' options and see if it was compiled with the "'--with-gd'"
     
  3. akany

    akany Guest

    0
     
    That is what the config says:

    './configure' '--prefix=/usr' '--datadir=/usr/share/php' '--mandir=/usr/share/man' '--bindir=/usr/bin' '--libdir=/usr/share' '--includedir=/usr/include' '--sysconfdir=/etc' '--with-_lib=lib' '--with-config-file-path=/etc' '--with-exec-dir=/usr/lib/php/bin' '--disable-debug' '--enable-inline-optimization' '--enable-memory-limit' '--enable-magic-quotes' '--enable-safe-mode' '--enable-sigchild' '--disable-ctype' '--disable-session' '--without-mysql' '--disable-cli' '--without-pear' '--with-openssl' '--with-apxs2=/usr/sbin/apxs2-prefork' 'i586-suse-linux'


    Anyway, I'm would update to a new version of php to fix that problem, but is there a way to do it with plesk or yast?
     
  4. ShadowMan@

    ShadowMan@ Guest

    0
     
    Looks like your OS is Suse, which I am not familiar with. There is no way with the Plesk interface, and I am not familiar with yast, other than that it is similar to up2date/yum/apt-get in function.

    Look for a Suse update site and see if you can find an updated php package. I did a quick search of the Novell update site and did not find any update to php, but someone out there may have one. Good luck! My boss and I quit working for Novell over a decade ago and we have never been happier!
     
Loading...