1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Problems with DNS behind Cisco PIX

Discussion in 'Plesk for Windows - 8.x and Older' started by arachnidservice, Mar 22, 2006.

  1. arachnidservice

    arachnidservice Guest

    0
     
    Greetings, I recently had a Cisco PIX put between our server and our providers connection. And am currently having a hard time getting the domains on the server to work.

    for the purpose of troubleshooting, here is the following examples

    we have 3 ip addresses (listed ones are fake)

    60.0.0.1
    60.0.0.2
    60.0.0.3

    the cisco pix is forwarding any requests to the following

    60.0.0.1 > 10.0.0.1
    60.0.0.2 > 10.0.0.2
    60.0.0.3 > 10.0.0.3

    The IPs in the server are the 10.0.0.x range, which the firewall translates to the public ips once it leaves the network.

    so domain1 = 10.0.0.1
    etc, etc.

    Now when trying to ping domain1 from an outside network, its coming up as 10.0.0.1, and naturally we are unable to route to it from outside the network.

    When setting the <ip> to the ip of the Firewall (to see if it worked like a gateway) in the default dns template under the server tab, the ip resolved to the firewall, and responded to pings, but did not let us route to domain1.

    is there something that needs to be reconfigured in plesk to resolve this ?
    any help or suggestions would be appreciated, thanks.
     
  2. arachnidservice

    arachnidservice Guest

    0
     
    Ok let me rephrase to make it easier to understand

    I have a Cisco PIX E105e NAT Firewall.

    It translates the following ips to internal ips

    60.0.0.1 = 10.0.0.1
    60.0.0.2 = 10.0.0.2
    60.0.0.3 = 10.0.0.3
    and vice versa

    one of my domains is working, i set it up by going on a suggestion from an old post here (took well over an hour to find it!)

    that post is: http://forum.plesk.com/showthread.php?threadid=27758&highlight=NAT
    the very last one, by sieb (thanks a ton sieb)

    however its not working for all my domains, each domain was set up just as the one that was working, almost identical, yet it does not work.
    also one that is working, is showing the plesk default page, and when i try logging into it via plesk (https:///www.domain1.com:8666)
    it brings me to a plesk log in, but rejects my username and password as if it was not really my own plesk system
    when going through another domain, or direct via the ip, it works fine! currently i am baffled as to why this is happening
    also having problems doing frame forwarding, any suggestions would be extremely helpful, i've seen other post reguarding similar issues that never seem to get awnsered, so im hoping one of thoes people have resolved it and will post the remedy.

    Thanks for your time.
     
  3. adrianTNT

    adrianTNT Guest

    0
     
    Hi.

    I think I have some of the same issues like you had.
    I ping my domain and it says it tried to ping 10.0.0.1 instead of normal ip (e.g. 21.21.200.200)
    Could you find what was the cause of this?

    Thanks.
     
Loading...