• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Problems with Plesk Migration Manager

G

greyboy

Guest
Hello,

We are trying to move many sites from a cPanel server to a Plesk v7.5.4_build75051209.14 os_RedHat el4 machine and are experiencing many problems.

The process goes like this.

1) I package up the sites using cPanel9.pl --no-compress --accounts=acctname
2) SCP the files over to the new server
3) copy and chown the files to /usr/local/psa/PMM/archives
4) copy the cPanel.xml file to /usr/local/psa/PMM/var/dump.xml
5) Proceed to use the PMM took from within Plesk.

However, we are seeing quite a few errors. Most seem to be OK anyway, but the database errors are not. This is common for almost every domain:

1. Failed deployment of database user username of database username_dbname
Execution of '/usr/local/psa/bin/database.sh' '--update' 'username_dbname' '-add_user' 'username' '-type' 'mysql' '-passwd' '' failed with the return code 1.
STDOUT:

STDERR:
Unable add user to database: Unable to create the database user: User username already exists.

[Plus many more...]

I believe the problem is that username is already assigned to another database, which is common. A single username can span multiple databases, so this script fails.

I see how to manually manipulate the psa database to account for this, but it's a tedious process.

Does anyone here have any experience they can share regarding this?

Thanks,
-N
 
Back
Top