1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

PSA 8.3 data-restore from prev. PSA8.x version?

Discussion in 'Plesk for Linux - 8.x and Older' started by joda, Jan 6, 2008.

  1. joda

    joda Guest

    0
     
    Hi all,

    I have a PSA8.0 backup, and during upgrade my server crashed.
    I have not reinstalled a new server with 8.3, and i have a backup-file from the previous server.

    I know this is not much information - but is there any problems having a backup file, from PSA8, and doing a restore on PSA8.3 ??

    Both the prev. server and the current one, is running Linux Debian.
     
  2. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
    No the format of the backup is the same for all 8.x systems, you should be able to use a 8.0, or 8.1 backup on 8.3. Versions lower than 8.0 require you to run it through the conversion utility.
     
  3. joda

    joda Guest

    0
     
    I have just tried to create the mapfile using the 8.3 version - and i got this warning:

    WARNING: Backup file has wrong signature for this server

    Is that something that i need to take care of?
     
  4. joda

    joda Guest

    0
     
    Okay, now i have a BIG problem. I don't know what this means, as i have not worked with python at all.

    # ./pleskrestore --restore /root/daily_uxser01_backup -level server -map /root/mappen -verbose
    WARNING: Backup file has wrong signature for this server

    WARNING! Restore with "-level server" switch brings server to exactly the same
    state, as was saved in backup file. All objects, not presented in the backup
    file (clients or domains) will be deleted. Proceed? [yes/no]: yes
    Traceback (most recent call last):
    File "/opt/psa/admin/share/supervisor/processor.py", line 116, in doActivityRunner
    newState = self.doActivity()
    File "/opt/psa/admin/share/supervisor/processor.py", line 817, in doActivity
    cmd.spawn(os.environ.has_key("PLESKRESTORE_MODE"))
    File "/opt/psa/admin/lib/python/subproc.py", line 238, in spawn
    proc.run()
    File "/opt/psa/admin/lib/python/subproc.py", line 193, in run
    BaseSubprocess.run(self)
    File "/opt/psa/admin/lib/python/subproc.py", line 177, in run
    self.wait()
    File "/opt/psa/admin/lib/python/subproc.py", line 197, in wait
    BaseSubprocess.wait(self)
    File "/opt/psa/admin/lib/python/subproc.py", line 185, in wait
    raise SignalException(self, os.WTERMSIG(status))
    SignalException: <unprintable instance object>
     
  5. webfors

    webfors Guest

    0
     
    same error here with a backup from 8.2.1 and attempting restore on 8.3.0:


    WARNING: Backup file has wrong signature for this server

    Returned this after spinning it's wheels for 10 minutes trying to create a map file.
     
  6. joda

    joda Guest

    0
     
    One new note, the "old" server was an Intel i386.
    This new server is AMD x86_64.

    I have verified that the content of the server is version 8.

    # ./pleskrestore -i /root/daily_uxser01_backup
    ------------------------------------------------------------------------
    Backup information
    Dump version: 8.3.0
    File: /root/daily_uxser01_backup
    Type: Server
    Comment:
    Date: Jan 6, 2008 10:57 AM
    Size: 1.66 G
    ------------------------------------------------------------------------

    How can i verify the backupfile itself, and check the content?
     
  7. joda

    joda Guest

    0
     
    Okay, now i have been able to extract all the data from the backup-file, into a simple directory.

    # ./backup-unpack extract -d /var/old-data /root/daily_uxser01_backup

    This tells me that the backup-file is OK, why can't i restore by using the pleskrestore application?
     
  8. joda

    joda Guest

    0
     
    Come on, anyone??

    Is there a problem with the Plesk Restore utility?
    - If so, how can i get all my 1.6GB Data into my server again? (without to much manual labour?)
     
Loading...