1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

psa continually crashing

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by DarrenHennessey, May 2, 2011.

  1. DarrenHennessey

    DarrenHennessey Guest

    0
     
    Hello,

    I lease a virtual private server which comes with a license for plesk panel. The VM is running CentOS 5.5.

    uname -a: Linux ip-173-201-178-174.ip.secureserver.net 2.6.18-028stab070.14 #1 SMP Thu Nov 18 16:04:02 MSK 2010 i686 i686 i386 GNU/Linux

    Problem Description:
    My Plesk panel will not stay running for more than an hour, currently. And when it does run, the email is sketchy at best.

    I started, 2-3 days ago with this problem and have tried everything from updating the VM to updating the Plesk panel. I even tried changing to Postfix and back to Qmail.

    Another symptom that's happened pretty well from day one is that named locks up as well. Since this problem has arisen, named has stopped locking up, but psa does instead.

    Steps to reproduce:
    Nothing, simply starting the service and waiting will net a crash.

    The error i get is:

    "psa dead but subsys locked"

    Which in itself means nothing except for the service has gone down and left its lock file.

    I do get the following errors in my /var/log/sw-cp-server/error_log quite often:


    2011-05-02 21:34:49: (mod_fastcgi.c.1337) Dynamic spawning with max_procs > 1 is not supported; setting min_procs = max_procs
    2011-05-02 21:34:49: (mod_fastcgi.c.1337) Dynamic spawning with max_procs > 1 is not supported; setting min_procs = max_procs


    I'd really like to get this sorted out as soon as possible, it's starting to eat up all my time, as i have to keep restarting services (like 2-3 times an hour).

    Thanks, in advance,

    Darren
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
  3. DarrenHennessey

    DarrenHennessey Guest

    0
     
    I'm on 9.5.4 now, will this still work?
     
  4. DarrenHennessey

    DarrenHennessey Guest

    0
     
    So the patch worked, sort of.

    Now i'm back to the same situation as before the psa service started crashing.

    The named service is periodically crashing.

    Any suggestions on how to fix this, or where i can locate more info on the psa specific issues with named are greatly appreciated.
     
  5. DarrenHennessey

    DarrenHennessey Guest

    0
     
    I think i might have found the problem with named.

    apparently bind 9+ has an option for "max-cache-size" that's not set, well, not in CentOS 5.5 anyway. If it's not set, it defaults to 0 which means unlimited. If your server doesn't have a lot of ram to begin with, like mine, it's possible that it could cache all the available memory and crash the service.

    So i set max-cache-size to 32M like so:

    options {
    .....
    max-cache-size 32M;

    .....
    };

    in my named.conf and restarted the service

    Hope that helps anyone else that might run into this frustration.

    Darren
     
  6. DarrenHennessey

    DarrenHennessey Guest

    0
     
    Just a quick update, apparently this has not stopped my named crashes... i'll update this more when i come across a solution
     
  7. DarrenHennessey

    DarrenHennessey Guest

    0
     
    Well, i've found that the named instance crashing is not 100% due to anything plesk is doing, it may be a separate issue, so i'll leave that one for now.

    That said, my plesk panel crashed again today, after being stable for a few days, after applying the patch specified by IgorG.

    This time in my log i'm still getting the notices from before:

    2011-05-07 08:22:46: (mod_fastcgi.c.1337) Dynamic spawning with max_procs > 1 is not supported; setting min_procs = max_procs
    2011-05-07 08:22:46: (mod_fastcgi.c.1337) Dynamic spawning with max_procs > 1 is not supported; setting min_procs = max_procs

    but now i'm also getting these:

    2011-05-07 01:06:30: (connections.c.299) SSL: 1 error:140940E5:SSL routines:SSL3_READ_BYTES:ssl handshake failure
    2011-05-07 01:14:59: (connections.c.299) SSL: 1 error:140940E5:SSL routines:SSL3_READ_BYTES:ssl handshake failure

    I'm starting to feel like the 9.5 panel is not going to work for me. Would upgrading to 10.x fix this problem?

    I will be honest and say i'm a little afraid to jump a major version with all the problems i'm having lately.

    Thanks in advance,

    Darren
     
  8. DarrenHennessey

    DarrenHennessey Guest

    0
     
    I forgot to mention my server is running CentOS 5.5 if that helps.
     
  9. DarrenHennessey

    DarrenHennessey Guest

    0
     
    well, my server just sent me 5000+ emails with no subject and no sender. qmail is going nuts.

    I really need help with this.
     
  10. DarrenHennessey

    DarrenHennessey Guest

    0
     
    I've upgraded my machine and now use psa 10, this can be closed.

    issue turned out to be simply not enough memory.
     
Loading...