1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Publish Failed: ItemAlreadyExists

Discussion in 'SiteBuilder' started by WillL, Feb 3, 2011.

  1. WillL

    WillL Guest

    0
     
    Hi all.

    I've tried researching this problem, and have had absolutely no luck. I'm currently evaluating Sitebuilder 4.5 to see if it meets my company's needs; unfortunately, I have had nothing but problems trying to get it up and running.

    I'm running Windows Server 2k3 (32-bit), with IIS 6.0. Our hosting method is a single server, wherein each domain is setup in its own directory with its own IP address. It's an extremely simple setup, at least in theory. All of the domain folders exist on a data partition, that for our purposes here we can just call D:. All of the domain folders are lumped together; let's call it D:\Sites\insertdomain.com\

    I preinstalled MS SQL Express 2005. I tried using MySQL at first (before finding out it won't work), then attempted MS SQL 2008 Express R2 (before getting the same error I'm about to describe), then I finally decided to try the asked-for 2005 just to see if anything changed.

    I installed Sitebuilder to D:\Sitebuilder, the Repository to D:\Sitebuilder\Repository, and the Websites to D:\Sites\. Windows is running on C:\ as per norm.

    Everything seems to go well (although I'm still fuzzy on whether I'll keep one host, or setup a host for each domain, since they're all treated as independent hosts with separate IPs as far as the FTP server cares). However, when I setup a site to a domain I already have setup in IIS, it will only Verify the Location or Publish if I remove the contents of the entire directory D:\Sites\domain.com\*. If any of the 4 folders pre-exist when I hit Publish, I get the following error: Error: Cannot publish site. FTP error: An unexpected exception has occurred. ItemAlreadyExists

    If I remove those 4 folders, and click Publish (or Verify the Location; the results are identical), it succeeds properly like it should.

    Looking at the Sitebuilder Log gives me the following:

    Log group details
    Level Error Group creation date 20:32:55 Last log date 21:32:45

    View last log
    View all logs (6)
    View first log

    Message Publish failed
    ---SWsoft.SiteBuilder.BO.Facade.PublishException: Publish failed: unknown exception
    ---SWsoft.SiteBuilder.Repository.PublicationException: ItemAlreadyExists
    Stack trace SWsoft.SiteBuilder.BO.Facade.PublishException:
    ---
    SWsoft.SiteBuilder.Repository.PublicationException: at SWsoft.SiteBuilder.Repository.FtpResources.FtpAdapter.<>c__DisplayClass7.b__6()
    at SWsoft.SiteBuilder.Repository.Resources.ProtocolAdapter.<>c__DisplayClass4.b__3()
    at SWsoft.SiteBuilder.Repository.Resources.ProtocolAdapter.Invoke[T](ObjectMethodInvoker fun)
    at SWsoft.SiteBuilder.Repository.Resources.ProtocolAdapter.Invoke(EmptyMethodInvoker fun)
    at SWsoft.SiteBuilder.Repository.FtpResources.FtpAdapter.CreateFolder(PathEx path)
    at SWsoft.SiteBuilder.Repository.Resources.ResourceItemsCollection`2.AddSingleOnly(PathEx path, DateTime created, DateTime lastWrite, Boolean readOnly)
    at SWsoft.SiteBuilder.Repository.Resources.ResourceItemsCollection`2.Add(PathEx path)
    at SWsoft.SiteBuilder.Repository.Resources.ResourceItemsCollection`2.SWsoft.SiteBuilder.Repository.IStringIndexedCollection.Add(String name)
    at SWsoft.SiteBuilder.BO.Facade.Publish.LocationChecker.PublishProbeFiles()
    at SWsoft.SiteBuilder.BO.Facade.Publish.LocationChecker.Execute()
    at SWsoft.SiteBuilder.BO.Facade.Publish.SitePublisher.Publish(PublishSession publishSession)
    at SWsoft.SiteBuilder.BO.Facade.Publish.PublishSiteCommand.b__0()
    at SWsoft.SiteBuilder.BO.Facade.Publish.PublishHelper.CheckPublishExceptions(CheckPublishExceptionsMethod a_method)
    at SWsoft.SiteBuilder.BO.Facade.Publish.PublishSiteCommand.Run()
    ---

    Logger SWsoft.SiteBuilder.BO.Facade.Publish.PublishSiteCommand
    Group hash 23DBB8A2
    Plesk Sitebuilder version 4.5



    Any clues or hints as to what I'm doing wrong would be much appreciated, as my boss is on my butt to stop "wasting time" on this.
     
Loading...