1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

qmail-inject: fatal: qq read error (#4.3.0)

Discussion in 'Plesk for Linux - 8.x and Older' started by gong, Dec 14, 2005.

  1. gong

    gong Guest

    0
     
    There is another post with this question:
    http://forum.sw-soft.com/showthread.php?threadid=21096

    I can send an email with: echo test|sendmail lala@lala.com but can't send through mail() from PHP.

    In the previous post somebody said to re-install the package because of permission problem. Which permissions are incorrect?

    And where can I find rpms for the RHEL3. The company which I rent my web server didn;t give me anything?

    thanks
     
  2. bandurao

    bandurao Guest

    0
     
    Hello,

    Try following Mail function.

    <?php
    $mail_to="test123@domainname.com";
    $mail_subject="Hello";
    $mail_from="test@domainname.com";
    $mail_body_client="Hello";
    mail($mail_to,$mail_subject,$mail_body_client,"FROM:". $mail_from);
    ?>


    As this works for me.
    You can contact me at bandurao@gmail.com

    Thanks,
    Bandurao
     
  3. gong

    gong Guest

    0
     
    not working

    that's excactly what doesn;t work :)
    mail returns false and in error_log of apache I get the qmail-inject fatal error
     
  4. bandurao

    bandurao Guest

    0
     
    Can I know the link from which you are accessing this, just to check the output.

    Thanks,
    System Administrator.
    Bandurao.
     
  5. gong

    gong Guest

    0
     
    http://www.rados.gr/test1.php

    source code:
    <?php
    $mail_to="hkosmidi@laboratorium.gr";
    $mail_subject="Hello";
    $mail_from="hkosmidi@laboratorium.gr";
    $mail_body_client="Hello";
    if(mail($mail_to,$mail_subject,$mail_body_client,"FROM:". $mail_from))
    echo "ok";
    else
    echo "OOOhhh";
    ?>
     
  6. bandurao

    bandurao Guest

    0
     
    Hello,

    Its working fine on my server.
    just give few mins I will check further and let you know.

    Thanks,
    System Administrator.
    Bandurao.
     
  7. gong

    gong Guest

    0
     
    it works for you :-(

    yep I saw your message.
    It worked for me some while ago but suddendly it stopped working.
    I didn't change anything...
     
  8. bandurao

    bandurao Guest

    0
     
    ok, now the fastes solution is just upgarde the plesk, it will be done in 5 mins and you can get all the RPMS from the following link:

    http://3es.atomicrocketturtle.com/atomic/

    My Friends site.

    Thanks,
    System Administrator.
    Bandurao.

    Feel free to contact me for any issues or any contracts at bandurao@gmail.com
     
  9. bandurao

    bandurao Guest

    0
     
    Steps to upgarde Plesk are as follows:



    Login to the server you are planning to upgrade, and get a root shell.

    First thing to do is to check whether or not the server is accepting "ping" requests. You need to check this because the plesk rpm in the pre-install script checks this, and if it gives no reply, it dies. So, run the following:

    ping localhost

    If you get nothing but this message for a couple secconds, cancel the command:

    PING localhost.localdomain (127.0.0.1) 56(84) bytes of data.

    When you cancel, you should see 100% packet loss, such as the following:

    --- localhost.localdomain ping statistics ---
    3 packets transmitted, 0 received, 100% packet loss, time 2015ms

    Ping is an icmp packet. First, you want to stop the firewall:

    service iptables stop

    Will output:

    Flushing all chains: [ OK ]
    Removing user defined chains: [ OK ]
    Resetting built-in chains to the default ACCEPT policy: [ OK ]

    Now, you have to make sure the kernel isn't going to ignore the ping requests either, run the following command:

    echo 0 > /proc/sys/net/ipv4/icmp_echo_ignore_all

    Now try the ping again:

    ping localhost
    PING localhost.localdomain (127.0.0.1) 56(84) bytes of data.
    64 bytes from localhost.localdomain (127.0.0.1): icmp_seq=1 ttl=64 time=0.071 ms
    64 bytes from localhost.localdomain (127.0.0.1): icmp_seq=2 ttl=64 time=0.040 ms

    --- localhost.localdomain ping statistics ---
    2 packets transmitted, 2 received, 0% packet loss, time 999ms
    rtt min/avg/max/mdev = 0.040/0.055/0.071/0.017 ms

    You are now ready to continue.


    mkdir psa

    What I did is basically make a /root/psa/ directory

    Now, move into the directory

    cd psa

    Recursivly copy the /etc/psa and /usr/local/psa directries into here. Make sure you name them as different files so you don't overwrite them.

    cp -rp /etc/psa/ etc_psa
    cp -rp /usr/local/psa/ psa

    Do a mysqldump of the psa database, nameing it psa.sql

    mysqldump --opt -u admin -p********** psa > psa.sql

    Looking at the directory you are in, it should look like:

    etc_psa
    psa
    psa.sql

    Now

    Expand the tarball archive:

    change directory into the "base", which contains all the core plesk rpms


    now test it
    rpm -Uvh --test *

    If test gives some dependencies then install those. Once done again test it.

    once done stop all plesk services.

    Now, run the rpm command to upgrade without the --test switch: rpm -Uvh *

    So on it goes, upgrading the server.

    When it comes to this point in the upgrade, it will pause the output:


    ===> Installing Quotas
    Trying to change mount options in /etc/fstab... done
    Checking quotas. This may take some time.
    his will take WAY too long, is isn't nessisary, so background the upgrade process with Ctrl-z

    [1]+ Stopped rpm -Uvh *

    Now, kill the quotacheck processes

    killall -9 quotacheck

    Now forground your shell back into the upgrade, to continue. It'll look something like this:

    fg
    rpm -Uvh *
    /usr/local/psa/bin/install_post.sh: line 16630: 5695 Killed quotacheck "$vhosts_fs" -vunfmc >>"$product_log" 2>&1
    Unable to check quota. Quota is not supported by your operating system

    All other things it does where it pauses for a while, are things that need to be done, and can take a bit of time if there are a lot of domains setup on the server. These things include, but are not limited to: installing chroot enviroment, updating dns records, etc

    When it finishes, you should get a message such as this one:

    ==================================================================
    All stages of the upgrade were successful.
    Plesk is now running on your system.
    To complete the system configuration process, please proceed to URL:



    Further, use the following commands to start and stop the system:
    /etc/rc.d/init.d/psa start and
    /etc/rc.d/init.d/psa stop respectively.

    WARNING: Some minor problems occured during upgrade. You need to *
    * check log file *
    * /tmp/psa_7.0.4_RedHat_9_build040723.13_upgrade.log *
    * to fix these problems. *

    ==================================================================
     
  10. gong

    gong Guest

    0
     
    upgraded qmail

    I just upgraded the qmail with --nodeps and now it's fine...

    thanks for your long post though I was afraid to upgrade the whole thing.

    Now what;s left is to make my webmail working. It stopped when I upgraded mysql to 4.1.13.
    When I try to login I am being redirected to the same login page without any notice. (if I provide a wrong pass it sais its the wrong pass)

    PS:I upgraded psa-hord and psa-imp but nothing changed :-(
     
Loading...