1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Qmail Issue

Discussion in 'Plesk for Linux - 8.x and Older' started by mohitmoudgil, Jun 12, 2008.

  1. mohitmoudgil

    mohitmoudgil Guest

    0
     
    Hi,

    Hi have installed Plesk 8.4 for linux on my server. Password authentication for SMTP is enabled in Plesk.

    Lets suppose one email address mohit@mydomain.com exist on the server. When I try to send mail from telnet to the same address it do not ask for any authorization and sends mails without any problem.

    Escape character is '^@]'.
    220 mydomain.com ESMTP
    helo test.com
    250 mydomain.com
    MAIL TO: mohit@mydomain.com
    250 ok
    RCPT FROM: mohit@mydomain.com
    250 ok
    DATA this is relay test
    354 go ahead
    Test is going on.

    I want to stop this and want any one connecting to my SMTP to authorize first with username and passowd.

    Please help me in this and let me know how can I achieve this.

    Thanks in advance

    Mohit
     
  2. wsani

    wsani Silver Pleskian

    28
    40%
    Joined:
    Mar 4, 2005
    Messages:
    509
    Likes Received:
    0
    Enable the relay feature under the mail section.
     
  3. S.Celik

    S.Celik Guest

    0
     
    Enable? ...
     
  4. rvogti

    rvogti Guest

    0
     
    Under Server->Mail, place the X's in the appropriate place...

    Relaying
    closed
    X authorization is required:
    POP3 lock time Min
    X SMTP

    Note that since the SMTP server is used by remote hosts to send you mail as well as by your users to send mail out, the server cannot ask for authorization until it sees the message. However, rest assured if it is a relay and authorization hasn't occurred, the message won't be forwarded.

    -Robert
     
  5. yurtesen

    yurtesen Guest

    0
     
    Do you understand that what you are saying will effectively stop you from receiving any mail because connecting mail servers (anyone) will be asked for authorization when they want to deliver mail to your domain? As long as you want to receive normal mail, there is no way that you can ask for authorization when somebody is delivering mail to your domain in the server.
     
  6. mohitmoudgil

    mohitmoudgil Guest

    0
     
    Yes, I understand but the problem is that we are getting too much of spam. Someone is sending mails from mohit@mydomain.com to mohit@mydomain.com using my SMTP.

    I cannot even ban the domain because its my domain from where mail is coming. Please help me out.
     
  7. yurtesen

    yurtesen Guest

    0
     
  8. rvogti

    rvogti Guest

    0
     
    I would really recommend using an RBL list to cut down on that sort of spam. Also, you can look in /usr/local/psa/var/log/maillog and see who is doing it, and block them from connecting to your server.
     
Loading...