1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Qmail Problem after Upgrade to 9.0.0: Need fully-qualified hostname

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by gwider, Jan 10, 2009.

  1. gwider

    gwider Guest

    0
     
    Good Evening All!

    Other than not being able to update to 9.0.0.2, the upgrade from 8.6 wasn't too bad.
    I'm only having one major issues with mail being sent to some recipient mail servers.

    I'm getting the following bounce message back:
    Remote host said: 504 <server>: Helo command rejected: need fully-qualified hostname

    In deed the bounce message sender now reads "MAILER-DAEMON@server", while before the update it read "MAILER-DAEMON@server.xxx.de. And "server.xxx.de" is a fully qualified hostname, while "server" obviously isn't.

    The server settings also show "server.xxx.de" as the set hostname. So it seems that Qmail is suddenly disregarding the latter part of the hostname. This doesn't really fit in with the other bugs, I've read about.
    I only realised it because my own mailaccount seems to check for proper hostnames in the header and many other's don't.

    While upgrading from 8.6. to 9, I got the first Autoinstaller Success message allright. Then I ran the Updater again, because there are usually left over packages to be updated. And I hoped to get 9.0.0.2. From that point on, I didn't receive any more server emails.

    Any ideas and some action from the Plesk Supporters would be greatly appreciated.
    Thanks!
    G
     
  2. gwider

    gwider Guest

    0
     
    Likely Solution or Workaround

    By gutfeeling I just tried to play with the hostname setting under Server Settings.
    I changed it from server.xxx.de to xxx.de and then back to the original value. And it seems to have corrected itself.
    I hope it helps someone else and maybe it can be fixed with the next .release.

    Good Night!
     
Loading...