1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

qmail question

Discussion in 'Plesk for Linux - 8.x and Older' started by imakalic, Dec 14, 2005.

  1. imakalic

    imakalic Guest

    0
     
    hi i noticed recently that my qmail messages seem to get stuck in the qmail queue and do not get sent out. i checked the queue and it says that there equal number of messages in queue and still to be preprocessed.
    there seems to be a 5 min delay before the finally send.

    this is when sending 1 or 2 emails. seemed to work before but now it doesnt and i dont know why its stopped

    only thing that ive done is restart my vps not too long ago
    which makes me think that is the problem

    ive checked my maillogs and they do not indicate any problems

    any ideas?

    thanks
     
  2. phoenixisp

    phoenixisp Silver Pleskian

    27
    57%
    Joined:
    Feb 2, 2002
    Messages:
    840
    Likes Received:
    0
    Try turning off reverse dns lookups by editing your smtp_psa and smtps_psa files. Add -Rt0 to the server_args line like:

    server_args = -Rto /whatever/is/there

    Then restart qmail. Adding the -Rt0 option to the smtp_psa file eliminates this delay time by telling the smtp to not do reverse lookups.
     
  3. imakalic

    imakalic Guest

    0
     
    cool thanks
    ill give that a go
    :)
     
  4. mparadis

    mparadis Regular Pleskian

    26
    23%
    Joined:
    Sep 18, 2003
    Messages:
    176
    Likes Received:
    0
     
  5. imakalic

    imakalic Guest

    0
     
    hey,

    your right i should've come back here with the results.
    Never really ended up trying the above as after reading the suggestion i first tried to restart my qmail service
    and it solved the problem
    i dont know why but for some reason whenever i restart my server, a virtuozzo vps, the qmail service decides to wait 5 min before sending out mail
    so now every time i restart i also stop and then start the qmail service afterwards. fixes the issue i had.

    i can see it wont help u but i hope that my problem/solution may help someone else with similar issues

    good luck
     
Loading...