1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

qmail virtualdomains file problem

Discussion in 'Plesk for Linux - 8.x and Older' started by codesmith, Feb 7, 2006.

  1. codesmith

    codesmith Guest

    0
     
    We have to occasionally disable domains/clients when they don't pay their bill. When they do pay it, we turn the domain back on. However, they can't receive email -- getting:

    Sorry. Although I'm listed as a best-preference MX or A for that host, it isn't in my control/locals file, so I don't treat it as local. (#5.4.6)

    I checked the /var/qmail/control/virtualdomains file and the domain entry is indeed in there but at the end of the list. If I move the entry back to its original position in the list then everything works. Obviously this is a pain to do everytime. Any idea what's going on?
     
  2. Gisele Grenier

    Gisele Grenier Guest

    0
     
    I had the exact same problem.
    disabled domain due to non payment yesterday
    re-enabled today
    mail errors were the same as yours.

    I got it working by running the following:

    /usr/local/psa/admin/sbin/mchk --without-spam

    it rebuild the config files but left spam assassin alone.

    now everything works ok.
     
  3. Cranky

    Cranky Guest

    0
     
    I think they fixed this in one of the latest Plesk 7.5.4 builds, which version are you running?
     
  4. Gisele Grenier

    Gisele Grenier Guest

    0
     
  5. Cranky

    Cranky Guest

    0
     
    Via ssh run:

    cat /usr/local/psa/version
    rpm -qa | grep hotfix

    ...and post the output here. It'll tell you the exact build of Plesk you're running.
     
  6. Gisele Grenier

    Gisele Grenier Guest

    0
     
    7.5.4 FedoraCore 2 75060321.20
    psa-hotfix5-7.5.4-fc2.build75060118.18
    psa-hotfix6-7.5.4-fc2.build75060321.20


    Gisele
     
  7. bcscomp

    bcscomp Guest

    0
     
    actually, that's not correct, i am having this problem with a new client's email, and have had nothing but issues since the 8.x upgrade's started.

    i am trying the /usr/local/psa/admin/sbin/mchk --without-spam fix though, and will see if that works

    /time passes/

    well in this instance the /usr/local/psa/admin/sbin/mchk --without-spam command worked.....

    Thanks
    Bill
    http://www.hybrid-hosting.com (kinda) Proudly Uses the Plesk Interface for it's Customers.
    (thinking of going with a different CP software if the problems don't stop though)
     
  8. Fury

    Fury Guest

    0
     
    I have had the same problem in Plesk 8.1, after running: /usr/local/psa/admin/sbin/mchk --without-spam the mail for this domain worked again.
     
Loading...