1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Redirected to https though SSL is disabled

Discussion in 'Plesk 11.x for Linux' started by Atramasis, Oct 23, 2012.

  1. Atramasis

    Atramasis Basic Pleskian

    13
    60%
    Joined:
    Oct 22, 2012
    Messages:
    42
    Likes Received:
    0
    I migrated a server from Plesk 10 to 11. Always everything went OK, but SSL was a mess. I had to reconfigure some things, now all but one domain is working.
    The broken domain seams to redirect to https:// although SSL is disabled for this domain. In the error log I see many:
    and when I open web statistics it redirects me to https://domain.com/plesk-stat/webstat/
    The homepage and admin (WordPress) does not work (HTTP Error 500), but some static html files and php work (why just some?)

    I tried much: turn SSL on and off, delete and create certificats, remigrate, delete and recreate hosting, reconfigure,... nothing helps.
    Where can I turn off SSL in real?
     
  2. abdi

    abdi Platinum Pleskian

    31
    18%
    Joined:
    May 14, 2006
    Messages:
    2,913
    Likes Received:
    60
    If its a wordpress website, login to the admin interface and disable SSL.
     
  3. Atramasis

    Atramasis Basic Pleskian

    13
    60%
    Joined:
    Oct 22, 2012
    Messages:
    42
    Likes Received:
    0
    As I wrote, I had no access to WP admin, but checked in DB, SLL was turned off.
    And webstats was not working, it was not only WP.
    And SSL was off in Plesk but webstats still trying to access the httpsdocs and linked to http[B]s[/B]://...
    I think it is a bug in migration. Or maybe with the legacy option "Separate SSL and non-SSL content" (or both?).

    I resolved it, here is how:
    In mysql, I turned same_ssl to false in the psa DB, table hosting. Then the compatibility mode appeared again in the "Hosting Settings for domain.com" in the panel. I turned SLL on, turned the compatibility mode off (it disappeared), turned SSL off.
    (I also changed the document root to httpsdocs and back again, not sure if it helped, I was doing all together.)

    Now it works.
     
    Last edited: Oct 24, 2012
  4. abdi

    abdi Platinum Pleskian

    31
    18%
    Joined:
    May 14, 2006
    Messages:
    2,913
    Likes Received:
    60
    Webstats on Plesk have always been accessed through "https://" as far as I remember by default ..But good to know you resolved it ..
     
Loading...