1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

register globals in plesk 9

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by aplicasolucion, Feb 2, 2009.

  1. aplicasolucion

    aplicasolucion Guest

    0
     
    hello, i have a old web that use globals var ina a subdomain: https://app.domain.com

    in /subdomain/app/conf i have a file vhost_ssl.conf with:

    <Directory /var/www/vhosts/domain.com/subdomains/app/httpsdocs>
    php_admin_value register_globals on
    </Directory>

    but no work.

    only work changing in php.ini register_globals = on, but is very insecure.

    sorry for my english.
     
  2. steogede

    steogede Guest

    0
     
    Three things:
    • Are you sure you really want to do this? is there not a new version of your app that you can upgrade to that doesn't require register globals? - it's a bit PHP3
    • You probably need to use 'php_admin_flag' as it is an on/off setting (i.e. a flag)
    • Have you ran '/usr/local/psa/admin/sbin/websrvmng -a' (manually stop and start your webserver if it still doesn't work)
     
  3. 105547111

    105547111 Silver Pleskian

    32
    30%
    Joined:
    Jul 13, 2006
    Messages:
    643
    Likes Received:
    2
    Ah registerglobals to on, scary!
     
Loading...