1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Rejected Email

Discussion in 'Plesk 11.x for Linux' started by Jayson, Jul 24, 2012.

  1. Jayson

    Jayson Basic Pleskian

    26
    23%
    Joined:
    May 10, 2005
    Messages:
    95
    Likes Received:
    0
    Hello,

    Seems like another problem with my recent migration to 11.09 from 10.4.x

    Customers are having email rejected because Postfix is attempting to send using their website ip, which is shared. In their DNS I have my email server listed as their MX. It is on a completely different dedicated ip address. Checking maillog I see dozens of rejections all with shared ip addresses of various hosting customers. None of these people have their own mail server and use mine by default.

    Anyone know if this is a bug, or configuration mistake? My email server should be sending out with the same ip address as eth0 shouldn't it?


    Thank you
     
  2. Nikolay.

    Nikolay. Silver Pleskian

    17
    35%
    Joined:
    Jul 1, 2012
    Messages:
    844
    Likes Received:
    2
    This behavior is due to a feature of sending mail from subscription IP address.

    Please make sure that your MX records have desired priorities.
     
  3. Jayson

    Jayson Basic Pleskian

    26
    23%
    Joined:
    May 10, 2005
    Messages:
    95
    Likes Received:
    0
    The customer only has one MX record and it's for my email server, priority is 10. My DNS has the same mail server with the same MX priority.
     
  4. Nikolay.

    Nikolay. Silver Pleskian

    17
    35%
    Joined:
    Jul 1, 2012
    Messages:
    844
    Likes Received:
    2
    Oops, sorry, right.

    Unfortunately, I can't remember right now how to disable sender ip feature or even whether you can disable it at all. Since it works only for Postfix, you can switch to QMail as a quick workaround. I'll get back to you in a couple of hours when I'll be able to search for ways to disable the feature.
     
  5. Jayson

    Jayson Basic Pleskian

    26
    23%
    Joined:
    May 10, 2005
    Messages:
    95
    Likes Received:
    0
    Thank you, that makes great sense. Before upgrading I was using Qmail, I figured since Postfix seems to be the future, I would use it. Doh!
     
  6. Nikolay.

    Nikolay. Silver Pleskian

    17
    35%
    Joined:
    Jul 1, 2012
    Messages:
    844
    Likes Received:
    2
    You should stay on Postfix, if possible. QMail is pretty much "dead" already. Updates for it are highly unlikely, new features are also unlikely to include support for QMail.

    That said, there is no simple way to turn this feature off. Hint for those that strife for knowledge: this feature is automatically turned on if "$features['SDD_Transport_Maps'] = true;" in "/usr/local/psa/admin/sbin/mailmng --features" output.
     
  7. Jayson

    Jayson Basic Pleskian

    26
    23%
    Joined:
    May 10, 2005
    Messages:
    95
    Likes Received:
    0
    I always thought it would be nice to bind the outgoing smtp IP to a particular clients domain (should be MX). Careful what you wish for I guess.. Great feature or not, my mail queue is starting to fill up. I see it's possible to bind a specific ip in /etc/postfix/main.cf by adding smtp_bind_address, but I don't want to affect users currently with dedicated ip addresses not using my domain for sending mail.

    Here's a previously unanswered similar problem,

    http://forum.parallels.com/showthread.php?t=209918
     
    Last edited: Jul 24, 2012
  8. Jayson

    Jayson Basic Pleskian

    26
    23%
    Joined:
    May 10, 2005
    Messages:
    95
    Likes Received:
    0
    /bump

    I hate to bump my own thread but I'm getting desperate. Does anyone have a solution for this aside from removing Postfix and installing Qmail? Many others must have faced the same problem.
     
Loading...