1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Remove SSL certificate installed to use the fallback wildcard domain SSL

Discussion in 'Plesk 11.x for Linux' started by SlashMarco, Oct 3, 2012.

  1. SlashMarco

    SlashMarco New Pleskian

    Oct 3, 2012
    Likes Received:
    Hello everybody, I have a problem with a ssl certificate installed on my domain inter.domain.com (example).

    It works perfectly, but now I have the necessity to remove it, since I installed a wildcard ssl certificate (*.domain.com) on the same IP where inter.domain.com is, because I want a more flexible solution to handle my domains. I installed this new certificate as the default certificate in plesk.

    I was able to install and verify the wildcard certificate and it works for subdomains with SSL protection disabled so far (which I obviously switch on to make it works), or for brand new subscriptions, but I can't remove the specific certificate previously installed on inter.domain.com.

    Once I disable the certificate from the domain settings, still it seems that the certificate is enabled, and when I try to delete it, plesk notifies me that I can't remove it. I red the docs and it seems I have to switch to another certificate to be able to remove the prevous, so I created a new self-signed certificate, but still I am not able to remove the 3rd part one.

    Any suggestions to make things work?

    I don't know if I explained myself well, but anyway thanks in advance :)
  2. Alexey.Plotnitsky

    Alexey.Plotnitsky Regular Pleskian

    Jan 19, 2012
    Likes Received:
    Hi SlashMarco,

    1) Did you use Nginx reverse proxy in Plesk ?
    If yes, then try to disable it.

    2) Try to rebuild domains' config files:
    /usr/local/psa/admin/sbin/httpdmng --reconfigure-all