1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Restore Backup made on 32-bit Windows to 64-bit Windows

Discussion in 'Plesk 9.x for Windows Issue, Fixes, How-To' started by ZoranV, Dec 17, 2010.

  1. ZoranV

    ZoranV Guest

    0
     
    When you restore a server backup file made on 32-bit Windows server to 64-bit Windows server there are a lot of problems.
    I've made a backup on 32-bit system. Plesk 9.5.3 Windows Standard 2008.

    Restoring to Plesk 9.5.3 on Windows Starndard 2008 R2 - 64 bit.

    Restoration was made without any error, according to Plesk .

    But....

    Because of location of C:\Program Files\ transferred to C:\Program Files (x86)

    1. Webstats are not working

    2. Scheduled tasks have restored tasks with "Program Files" instead "Program Files (x86)" and none of them are working

    3. I can't install any application to any domain - Plesk is coming up with this error
    "The web application requires the resources which are not currently available
    The type of databases used on this server is not suitable for this application. "

    Both MySQL and MSSQL are working !
    Plesk is showing for MySQL "Database server version 0 " - NOT OK but it's working ?!?!?
    For MSSQL is showing "Database server version 9.00.4053 " - OK - also working ?!

    4. MSSQL Server can NOT be started after first restart like Network Service ?!?!
    It also can NOT be started as LOCAL SERVICE ?!?!

    [SOLVED] by starting it as LOCAL SYSTEM ?! and that is the only way MSSQL is working.

    5. WebAdmin for MSSQL is showing error page - It can be fixed with
    cd %plesk_bin%
    websrvmng.exe --reconfigure-sqladmin
    defpackagemng.exe --fix --type=sqladminmssql

    But... when you restart windows, same error, so I have to apply above 3 commands on every restart
    I've tried every single option on Plesk reconfigurator, same result every time.

    6. ASP error HRESULT: 0x80070005 (E_ACCESSDENIED))

    [SOLVED]
    I had to add the following at the end of my disksecurity.xml

    <Entry AccounType="1" Account="Psacln" Path="C:\Windows\assembly" AceFlags="FilesOnly" AccessMask="Read" EntryFlags="0x0" />

    Then run "%plesk_bin%\applysecurity" --apply


    If you have solution for problem 1 and 3 it will be appreciated .

    Thanks,

    Zoran
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,543
    Likes Received:
    1,240
    Location:
    Novosibirsk, Russia
    #60383

    I have forwarded it to developers. I will inform you with results of investigation as soon as I receive it.
     
Loading...