1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Restored my plesk - need some help

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by Espen Ursin-Holm, Mar 29, 2009.

  1. Espen Ursin-Holm

    Espen Ursin-Holm Guest

    0
     
    Hi,

    I restored my plesk using the restoretool and it worked out great.

    The only problem I have now is that when I access my panel:

    https://ns1.serverland.no:8443/

    I get this message stating: "No SP with id=vlomy3cqgs8f1avila4hntnllcqq1myu7es"

    (Try the URL yourself)

    How can I fix this ?

    Thanks

    Regards
    Espen Ursin-Holm
     
  2. Michael Kittlitz

    Michael Kittlitz New Pleskian

    19
    85%
    Joined:
    Apr 14, 2009
    Messages:
    11
    Likes Received:
    0
    I've got the same Problem now after restoring a two month old backup:

    No SP with id=f8cv4xxmcnu61o5s04yt86uiqcpcue467c1

    Maybe the Backup was made by Plesk 9.0 (about two Month old), but the Plesk-Panel I installaed is 9.01 - could this lead to this problem?
    The Restore itself worked pretty well - most Domains are online again - some have not been restored, but I can't do anything while I can't access the Controll Panel.

    Is there any solution?
     
  3. JakeC

    JakeC Guest

    0
     
    This happened to me, and it was caused by the fact that I had set the default domain for Plesk on my old server to a domain that I pointed to a new IP address on a different server during the migration process. If you edit your hosts file locally on your computer and point the default domain to the old IP address, then you should be able to view the Plesk CP on the old server.
     
  4. Michael Kittlitz

    Michael Kittlitz New Pleskian

    19
    85%
    Joined:
    Apr 14, 2009
    Messages:
    11
    Likes Received:
    0
    Actualy I figured out, that this had happened because I made a manual mysqldump with the old server before and then restored the whole dump to the just freshly set up system.
    This does ruin the psa-tables, obviously PLESK encodes everything for each setup individualy.

    Maybe a dump of the freshly set up server, then restoring the old complete dump and then integrating the just made dump by re-restoring it might work.
    I did not test that though.
    The second time I restored the critical informations manualy, since I ran out of time on the life system.
     
  5. realaaa@

    realaaa@ Basic Pleskian

    23
    70%
    Joined:
    Mar 16, 2006
    Messages:
    67
    Likes Received:
    0
    Just had the same issue, so let me put some notes here, as this thread seems to be the only place that can be googled by "No SP with id=" string.

    This error effectively means that there is no Service Provider with such ID. This in turn means that your Plesk server uses Single-sign on (SSO).

    If you have no idea what is all this SSO stuff about you can just disable it and move along:

    Code:
    # /usr/local/psa/bin/sso --disable
    
    If you do use SSO, then you'll have to investigate. Basically it means that server which is specified in SSO configuration has no information about the server which has this login problem. While server with login problem tries to come over to SSO server and say like - hey, I'm Plesk and my name is vlomy3cqgs8f1avila4hntnllcqq1myu7es, and eventually SSO server being totally not impressed with this.

    You can start investigation of the problem by checking who is your SSO server:

    Code:
    # /usr/local/psa/bin/sso --get-prefs
    SSO on
    sso server url: https://192.168.1.1:11443
    
    And then checking the following files on the SSO server:

    Code:
    /etc/sso/sso_config.ini
    /etc/sw-cp-server/applications.d/sso-cpserver.conf
    /var/lib/sso/sso.db
    
    Most probably poor Plesk tried to query some other SSO server or the SSO server really has no such ID in it's sqlite database, which is bad news for you then :)

    Hope this helps.
     
    Last edited: Jun 25, 2009
  6. Yeolegood

    Yeolegood Guest

    0
     
    In case you received "bad news" and no sp_id exist in config_param table (sitebuilder3 database) you can reregister SSO usung commands below:
    (Note!) It will delete all SSO accounts and create new ones.

    /usr/local/sitebuilder/utils/sso_config unregister

    /usr/local/sitebuilder/utils/sso_config register https://your.sso.server.com:11443/
     
  7. SpongebobS

    SpongebobS New Pleskian

    6
     
    Joined:
    May 25, 2013
    Messages:
    1
    Likes Received:
    0
    Hi Trollface

    We have recently tested the restore procedures from Plesk 11, and I had exactly the same problem as you.

    Here is a procedure that should work:

    Shorthands:
    PBM = Plesk Business Manager
    PPP = Parallels Plesk Panel

    • Reinstall OS
    • Reinstall Plesk (with business manager)
    • Initialize Plesk / Insert License key
    • Delete ALL default Plans (there are three tabs on that page - delete everything)
    • Don't initialize PBM (not sure if this matters)
    • Disable SSO as root:
      Code:
      /usr/local/psa/bin/sso --disable
    • Restore full PPP backup (we have done gui, CLI should work too)
    • Backup restore scripts mess up permissions on two very important files:
      Code:
      chmod 0640 /usr/local/psa/var/sso.idp.pem
      chmod 0640 /usr/local/psa/var/sso.sp.pem
      chown psaadm:sw-cp-server /usr/local/psa/var/sso.idp.pem
      chown psaadm:sw-cp-server /usr/local/psa/var/sso.sp.pem
      /usr/share/plesk-billing/sso --command=repair-all
    • Restore PBM (billing) database (KB 5300):
      Code:
      gunzip -c billing.sql.gz | mysql --default-character-set=utf8 billing
    • To be sure, disable SSO once again:
      Code:
      /usr/local/psa/bin/sso --disable
    • Log in to plesk, navigate to PBM. It will probably ask you for your password again.
    • Now you have to go to PBM -> All Settings -> Hosting panels
    • Click on Plesk Unix (if you are using Linux)
    • Click Edit on the RIGHT SIDE (there are two edits)
    • Insert Password
    • Click OK
    • Click on Plesk Unix again
    • Click Reconnect
    • Wait for the syncing to complete (check on the homepage of PBM)
    • If some sync tasks are taking too long to complete, click them where it says "syncing", and then select all and click sync.
    • Go back to PPP and go to Service Plans
    • Click on every individual plan and on the bottom check the long sync description and click OK
    • Do this for every plan you have from PPP
    • Check back in PBM to see if everything matches


    SSO Should be enabled now, after doing the "reconnect" thing


    There is still one problem that we saw. No Periodic tasks in the Tasks menu in PBM.... We need a fix for this ASAP!


    Please, if someone from Parallels Plesk Engineering team could see this issue, please repair your restore scripts so that SSO certs don't get messed up

    Aslo, please provide us with a way to re-enable PBM without having to go throught this huge procedure


    To recreate this problem is quite easy

    Install Plesk with licence (probably trial works too)
    Create a few plans / customers / subscriptions in PBM
    Create test content on those subscriptions
    Full backup
    billing dump
    and repeat the above procedure.

    The tasks in PBM never get restored...

    Please help!
     
Loading...