1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Restoring Plesk Database Version

Discussion in 'Plesk for Linux - 8.x and Older' started by reckless, Feb 4, 2005.

  1. reckless

    reckless Guest

    0
     
    I had a problem with upgrading Plesk 7.1.6 to Plesk 7.5.2 (FreeBSD 4.9) and now the Qmail service does not work.

    I backed up the /usr/local/psa directory before the failed upgrade and then restored it when the upgrade did not work.

    When I tried to re-run the installer / upgrade script, the following error appears:

    --------------------------------------------------

    Making some checks before upgrading

    Now BIND server shutting down...

    Trying to stop BIND server... done
    Trying to start BIND server... done

    BIND server starts Ok.

    Trying to start MySQL server... done
    Trying to establish test connection... connected
    Trying to stop MySQL server... done
    VERSION MISMATCH:
    PLESK DATABASE VERSION: 075
    PLESK INSTALLATION VERSION: 071

    ERROR while trying to check version match

    --------------------------------------------------

    How do I go about restoring the PLESK DATABASE VERSION to 071??
     
  2. jmhoms

    jmhoms Guest

    0
     
    It have had the same problem with FreeBSD 4.10-RELEASE-p2,
    upgrading from Plesk 7.1.5 to 7.5.2.
    As my experience, the instalation seemed to freeze after installing the extra aplications, before postnuke, so i deceided press ctrl+c, due to the logs info, that said that version 7.5.2 was correctly instalated And prior version was already uninstalled.
    After rebooting services, i have found out that mail was not working, so i tried to install the hotfix. The same problem then:
    VERSION MISMATCH between database 075 version and 071 product version.

    As the server was not fully working, i have tried to fix the problem as soon as posible, so i inserted the next SQL instruction in MySQL to register the instalation:

    insert into upgrade_history values(now(),'7.5.2 FreeBSD 4.9 75050202.12','0752');

    I have also edited the file in /usr/local/psa/version changing
    the existing info by this one: 7.5.2 FreeBSD 4.9 75050204.18

    After this changes, i have been able to execute the hotfix and mail has gone active again, after having been down for a while.

    The actual situation is that everything seems to work ok, but i suspect that not all the installation has registered correctly, because in the component button at the control panel, doesnt show all the correct versions, including some software that appear as not installed, (i.e, psa-qmail & psa-proftpd.)

    Is there anybody there that can suggest what's the best thing to do to fix this problem?
    cheers
     
  3. reckless

    reckless Guest

    0
     
    I gave up with trying to fix my problem. I ended up installing a fresh copy of plesk and manually putting all the website & database files in the new Plesk installation.

    I managed to save the emails, however copying them to the new installation (after setting up the same mail accounts) didn't work as planned.

    I had to look at the old 'psa' database to retrieve all the user accounts and domain settings, which took quite a while.

    I wouldn't recommended this method to fixing to the problem (I was lucky enough to have a small amount of domains) expecially if you have heaps of domains and users. However, the configuation of the server seems to be correct. But I have lost logs, stats and history (i.e. they are backed up but not configured with the new plesk)
     
  4. jmhoms

    jmhoms Guest

    0
     
    i feel lucky then :)
     
Loading...