1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

root@localhost problem

Discussion in 'Plesk for Linux - 8.x and Older' started by modom, Jul 4, 2005.

  1. modom

    modom Guest

    0
     
    I have a problem with the email root@localhost not working on centos 3.5 with plesk.

    This has always worked in the past. Anytime I test my ecommerce store the default email address has been root@localhost and has sent an email to my domain email address when testing. Just recently this has stopped working. The ecommerce store is php. I contacted the ecommerce store developer and root@localhost works for him.

    This is a reply from plesk about cgi recently on my cgi forms that were working, stopped working, and somehow started working again without anyone finding the problem:
    >>>>>>>>>>>>>
    "Actually root@localhost shouldn't work at all. The point is that qmail unlike sendmail is unable to pass messages via the system mail delivery into the /var/spool/mail/username file. It works only via SMTP. Please use an actual mail address in your cgi scripts."
    >>>>>>>>>>>>>>

    Since the ecommerce store is php and NOT cgi and root@localhost has been working for months is there someplace I can look to try to find the problem?

    This is what is listed in /etc/hosts:

    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1 localhost
    63.247.80.42 godslove.designhosting.biz godslove

    Thanks!
     
  2. phoenixisp

    phoenixisp Silver Pleskian

    27
    57%
    Joined:
    Feb 2, 2002
    Messages:
    840
    Likes Received:
    0
    I believe your hosts file should look like:

    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1 localhost.localdomain localhost
    63.247.80.42 godslove.designhosting.biz godslove
     
  3. modom

    modom Guest

    0
     
    Thank you but still doesn't work.

    I know there is some way to configure the server to send email to root@localhost but apparently it was turned off or disabled during the last upgrade or maybe I'm just dreaming that this was working for months and then stopped.

    Is there a way to turn this feature on or off?

    Thanks!
     
Loading...