1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Safe mode subdomain

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by ErwanG, Nov 30, 2010.

  1. ErwanG

    ErwanG Regular Pleskian

    20
    57%
    Joined:
    Apr 29, 2010
    Messages:
    121
    Likes Received:
    0
    Hello,

    I've a problem with safe mode in a subdomain.
    I've put "safe mode" OFF with the control panel to the main domain.
    But when i execute files, i've always the message :

    I've create a vhost.conf in "/var/www/vhosts/<domain>/subdomains/visuels/conf" with

    And after :

    And

    But it doesn't work. Always safe mode problem.

    A solution ?

    Thank you.
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,576
    Likes Received:
    1,244
    Location:
    Novosibirsk, Russia
    Do you have PHP as apache module or as fastcgi?
     
  3. ErwanG

    ErwanG Regular Pleskian

    20
    57%
    Joined:
    Apr 29, 2010
    Messages:
    121
    Likes Received:
    0
    Apache module
     
  4. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,576
    Likes Received:
    1,244
    Location:
    Novosibirsk, Russia
    Do you have safe_mode = Off in /etc/php.ini ?
     
  5. ErwanG

    ErwanG Regular Pleskian

    20
    57%
    Joined:
    Apr 29, 2010
    Messages:
    121
    Likes Received:
    0
    Yes.

    If i put SAFE MODE=Off in php.ini, can we have SAFE MODE=On for the others website ?
     
  6. ErwanG

    ErwanG Regular Pleskian

    20
    57%
    Joined:
    Apr 29, 2010
    Messages:
    121
    Likes Received:
    0
    It's ok now.

    Thank you.
     
  7. Co Gol

    Co Gol Guest

    0
     
    I have the same problem but with fcgi.

    Main domain is in fcgi with safe_mode OFF, but on all subdomains i got safe_mode ON and no option to turn it OFF via Plesk (9.5.4).

    I need help couse i have to install Magento on a subdomain with fcgi (e.g. shop.example.com) and Magento wnats safe_mode OFF.
     
  8. dataanywhere

    dataanywhere New Pleskian

    22
    23%
    Joined:
    Nov 4, 2004
    Messages:
    7
    Likes Received:
    0
    Any chance you could enlighten some of us as to how you managed to resolve this?

    I've been fighting with this for a while. At one point, it was off, but now it's on again. Many files in the /var/www/vhosts/<$DOMAIN>/conf folder that have php_safe_mode on and most have it off. The most current config files are off. The Plesk Panel shows it's unchecked (meaning off) for safe_mode for the domain, yet PHPINFO( INFO_ALL) states that it's on.

    Thanks,
    Geoff
     
Loading...