1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Sending mail to external mailserver for domain not working after autoupdate

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by CoelnConcept, Oct 9, 2012.

  1. CoelnConcept

    CoelnConcept New Pleskian

    Oct 9, 2012
    Likes Received:
    Situation: There are several domains like example.com, example.net etc on the server. All domains have aliases like example.org. All domais do not use the postfix mailservice on the PLESK server for receiving mail but an external thirdparty mailserver mail.example.com. Therefore mailservice for all domains is switched off in the panel and all domains have custom MX records which point to mail.example.com. The postfix mailserver on the PLESK server is only used for sending mails which may be generated for example by a contact form on the domains for info@example.com.

    For several weeks now there is following problem after PLESK performs an automatic (micro)update: postfix does not send the mails to external server mail.example.com but tries to handle the mail locally. This fails because there are no accounts info@example.com etc configured on the server. Mail is bounced and dropped (lost) after a while.

    To fix this errror we must manually by hand first active the mailservice for all domains in the panel (panel still reports the mailservice is deacticvated) and then disable mailservice again. Seems like this forces the panel to rebuild the postfix configuration.

    Autoupdate worked several month without this symptom, but for several weeks now produces this error after each run.

    Software is Parallels Plesk Panel v10.4.4_build1013111102.18 os_Debian 6.0. Anyone else with this error or a solution ?

    Regards, Jens Killus