1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

SFTP not working

Discussion in 'Plesk for Linux - 8.x and Older' started by dsch, Oct 24, 2008.

  1. dsch

    dsch Guest

    0
     
    Hello

    I have had long problems with this. I have been able to set up TLS/SSL support at least, but really want SFTP to work. I have chrooted shell access on, but when I connect it simply quits

    It accepts the password, but as soon as that is done it quits.

    with -v option;

    What to do?? I have Plesk 8.6 on a Debian server. It has worked before, but since some upgrades ago it didn't work anymore. It would be really nice to block out obscure FTP login, so everything is just a tad more secure :)
     
  2. dingding

    dingding Guest

    0
     
    I had the same Problem with 8.6. on a Debian Server. Fixed it by matching the Subsystem entry in /etc/ssh/sshd_config with the actual location of sftp-server in the chroot environment.

    The entry pointed to:
    Subsystem sftp /usr/lib/openssh/sftp-server

    But the actual path to sftp-server in the chroot was:
    /usr/lib/sftp-server

    You can fix that by moving sftp-server in the chroot "template" in /var/www/vhosts/chroot/ and recreating the chroot with /usr/local/psa/admin/bin/chrootmng or by editing the entry in sshd_config.
     
Loading...