1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Slow FTP uploads

Discussion in 'Plesk for Linux - 8.x and Older' started by stainfotech, Jun 14, 2005.

  1. stainfotech

    stainfotech Guest

    0
     
    I'm running Plesk reloaded 7.5.3 on RedHat 9, it seems that the ftp upload speed is limited to 2.5 kbps, which is really painful. I thought Plesk used ProFTPD as it's FTP server, but that does not appear to be the case as the proftpd.conf appears to be almost empty. Any ideas?
     
  2. mac0310

    mac0310 Guest

    0
     
    Sorry that this isn't an answer but I wanted to add that I have had terrible experience with all aspects of FTP usage in Plesk (7.*). The biggest problem I am experiencing is that FTP sessions keep stalling and the throughput backs off until the connection is useless. I complained to my service provider but as it turns out there is something very unreliable with what Plesk has done to the FTP service. I have used servers at three different providers and FTP is always a problem. Unless it's really small transfers I usually end up packing all the files and using 'wget'. If anyone has any ideas on how to make the Plesk installation provide a REAL FTP service I would like to hear about it.

    PS I wonder if this has anything to do with the fact that the migration service is just as unreliable.
     
  3. stainfotech

    stainfotech Guest

    0
     
    It sounds like you have the same problem. Dataflow seems to be stalling and it uploads in bursts, rather than steady flow, averaging about 2.5 kbps. I'm running a stand-alone ProFTPD server on the same connection and I can upload at 30 kbps with no problems, so I know it's got nothing to do with my connection at home or where the servers are.
     
  4. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Yes, Plesk is using ProFTPd. Make sure you turn off ReverseDNS and IdentLookups.

    Those almost always contribute to speed issues. Also, you may want to comment out some of the logging options, unless you're running with anony.

    You can also read this doc on tuning proftpd
    [Edit: whoops, wrong link. That was supposed to be posted in another thread about ftp abuse....]
    Now I can't remember what the other link was that I wanted to post here....alzheimers...
     
  5. voodoochile

    voodoochile Guest

    0
     
    I would probabally NOT use most of the stuff in the above "Performance Tuning" for Proftpd, unless you really want to send your clients eslewhere. =)

    The above URL has nothing to do with the speed issues you're seeing.

    I've dealt with this before and after the last PSA upgrade I'm running into it again myself, give me a few and I'll letcha know what the deal is.


    Edit:

    Interesting side note, the only changes between my proftpd configs from7.5.2->7.5.3 are as follows. heh
    Code:
    17c17
    < PassivePorts 8500 9000
    ---
    > PassivePorts  8500 9000
    54a55,61
    > 
    > # Disable PAM authentication
    > AuthPAM off
    > 
    > # delay on login off
    > IdentLookups off 
    > UseReverseDNS off
    
    The passiveports declaration is just spaced slightly differently. And the only additions are the identlookups off, usereversedns off and authpam off. heh.
     
  6. stainfotech

    stainfotech Guest

    0
     
    It can't be what jamesyeeoc sugested because my IdentLookups and UseReverseDNS are already set to off. I'm assuming it must me some kind of a bug.

    I'm really stuck on this one.....no idea what's going on! :(

    Might have to ditch Plesk for something else instead. :/
     
  7. jamesyeeoc

    jamesyeeoc Guest

    0
     
    My suggestion was not that it 'had' to be, but one thing to check.

    I have done a number of upload tests with 7.5.3 servers this week, all upload speeds for files ranging from 2MB to 500MB have uploaded to the servers at speeds ranging from 650kBps to ~900kBps.

    My local connection is T1, using SFTP, servers have full AV coverage as well as my workstations.

    Some servers were default Plesk (fresh install), some were production servers.

    I also compared it to Plesk 6 servers upload speeds which were slightly slower, may be due to slower hardware in those servers.
     
  8. stainfotech

    stainfotech Guest

    0
     
    Hi jamesyeeoc, I see your point but I don't see what else the problem could be. My other stand-alone ProFTPD server on the same connection is running fine and proftpd.conf is identical. HTTP speeds are also excellent and I even tried uploading via SSH, that was good as well.

    Maybe I'll try re-installing ProFTPD, see what happens.
     
  9. dstanley

    dstanley Guest

    0
     
    I have had the same problem on 2 production servers running the latest plesk patch. They worked fine in 7.5.2 but when i upgraded upload any file on any account and a zero byte (0kb) file is created and a few mins later it says can't write file. So basically i've to upload everything via SSH.

    Both are totally differnt specs and distributions, FC2 & Suse

    I'm trying unsuccessfuly at the moment to get proftpd into debug mode.

    Is there an alternative to proftpd? Running a different server?
     
  10. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Of course you could always setup a different FTP package running standalone, just make sure you either run it on a different port, or change the port that the psa proftpd is running on. (as stainoftech mentioned in an earlier post)

    None of the 7.5.3 servers I have ever dealt with directly have had ftp issues, other than basic settings like max file upload size :) (i am knocking on wood right now)
     
  11. are_eye_see_kay

    are_eye_see_kay Guest

    0
     
    I'm going to have to agree with the neysayers on this one james. Even SW-Soft acknowledges the fact that their ProFtpd setup is flawed. The problem isn't in the conf file though because as was stated earlier the upgrade to 7.5.3 addresses the earlier versions config issues. I'm wondering if the proftpd version has something to do with it. Which version of proftpd does 7.5.2 run on fc1. If it's the same version, then I have no idea. I'm having the same problems everyone else is having, and I'm getting tired of it. In 7.1.X ftp was beautiful. That was only last year. Of course we've been through countless useless updates, so who knows what's been bungled by now.
     
  12. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Yes, I was not saying that problems do not exist, just that I have been lucky and not had any on the server's I deal with.

    I do agree that running theirs under xinetd obviously has some problems, just from the number of posts, and the number of updates already released this year is a bit much. I just wish they would release an update which actually fixed all major issues and be done with it. (I'm not holding my breath).
     
  13. dstanley

    dstanley Guest

    0
     
    i found that removing proftpd from the inetd and running it as standalone fixed all my problems with ftp. Just make sure it starts up on boot and all should be fine.
     
Loading...