1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

SMTP Server Settings

Discussion in 'Sitebuilder 4.0 for Windows' started by snyhof, Oct 26, 2007.

  1. snyhof

    snyhof Guest

    0
     
    I was having trouble with my formfeed (contact) forms. It was working but something must have changed and we made some setting adjustments and made a change to the web.config file to get it to work. So it is working, but it seems something is not working when a site is created.

    SMTP Server Settings
    SMTP server host*
    localhost

    SMTP server port*
    25

    ...from email...

    The server host was set to my incoming SMTP
    mail.xxxxx.com
    But we changed the web.config to localhost to make this work.

    *************
    <smtp deliveryMethod="Network" from="steve@planadream.com">
    <network host="localhost" port="25" defaultCredentials="false" userName="
    *************

    However, when a site is created the network host="mail.xxxxx.com" like the settings were set before. Now I have it set to localhost in the SMTP Server Settings but doen't carry into the web.config file when created.

    Any ideas of how this can default to localhost?
     
  2. Alex Klimov

    Alex Klimov Guest

    0
     
    When site is creating following SMTP settings gets used: Admin panel -> Server link in left Menu -> SMTP settings. These settings are applicable to Preview sites. When site gets published Host's SMTP settings are gets written into web.config.

    p.s. I found out, when you change settings in admin panel - existing Preview sites just ingore new settings and continue use old. So you are forced to change SMTP settings manually for this sites. This will be fixed in next version.
     
Loading...