• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Solved: DNS Server Crashed, failed to start

Status
Not open for further replies.

Xavier12

Regular Pleskian
Hey guys,

It seems the servers dns will not resolve and has crashed. When starting the "Named" service, here is the error:

Error in named configuration:
zone 0.0.127.IN-ADDR.ARPA/IN: loaded serial 20010622
zone 215.170.107.in-addr.arpa/IN: loaded serial 1433121512
zone lanewgirl.com/IN: NS 'ns.mydomain.com' has no address records (A or AAAA)

zone mydomain.com/IN: not loaded due to errors.

_default/mydomain.com/IN: bad zone

zone mydomain2.com/IN: NS 'ns.mydomain2.com' has no address records (A or AAAA)

zone mydomain2.com/IN: not loaded due to errors.

_default/mydomain2.com/IN: bad zone

Please advise, thanks
 
The solution would be to use a valid dns-template or at least add an a-record to that zone.
Are you using plesk as primary dns for that domain?
 
Hi Oliver,

Thanks for the response. Yes. Zones were set up. The issue was that we tried to duplicate a site and the vps crashed because of no disk space. We deleted files to get the vps back in working order. Since then, the DNS issue occurred.

When starting DNS in plesk, here is the error

Error: Unable to make action: Unable to manage service by dnsmng: dnsmng: Service /etc/init.d/named failed to start
('--start', 'dns')

Please advise, thanks
 
RESOLVED

Seem to have fixed it by going to the default template dns settings in Tools & Settings / DNS Template, then resetting to default. From there, re-add nameserver A Records, etc.
 
Status
Not open for further replies.
Back
Top