• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

[SOLVED] Error setting ipv6 on Plesk

Agauser

New Pleskian
Background: Server with 4 domains. Centos 6.7
Plesk was upgraded some days ago to 12.5.30_build1205150826.19. No problem these days.

Just added new domain, during setup no ipv6 was added as was no planned initially. Everything ok, new web y Wordpress, old web in html copied to archive directory and phopbb forum running also ok.

Emails from Plesk came rejected from Gmail (the destination mail account for new customer) for a problem with ipv6 so decided to add an ipv6 to this customer/domain/suscription. Couldn't achieve. Neither on IP addresses on Tools section.

I went back to IP Addresses on Tools and tried to assign IPv6 to domain with no results.

When trying to reread I receive this error:

[root@www ~]# /usr/local/psa/bin/ipmanage --reread
IP addresses were reread from the system.[2016-01-25 09:52:17] ERR [util_exec] proc_close() failed ['/usr/local/psa/admin/bin/apache-config' '-t'] with exit code [1]
[2016-01-25 09:52:19] ERR [panel] Apache config (14537119370.09169300) generation failed: Template_Exception: Syntax error on line 26 of /etc/httpd/conf/plesk.conf.d/server.conf:
The address or port is invalid

file: /usr/local/psa/admin/plib/Template/Writer/Webserver/Abstract.php
line: 75
code: 0
​

Also, a new IP is listed at top of IP list:

IP Address Interface IP Type Resellers Sites
/0.0.0.0 eth0 dedicated 0 0
​

And also a new error on one of the shared available IPv6 addresses (is from other working domain):

This IP address is not configured properly. Repair​

If I click on repair this error is showed:

Error: ifmng failed: SIOCSIFADDR: File exists /sbin/ifconfig eth0 add 2a01:...::3/64 exited with non-zero status 1​

In Webserver Configurations Troubleshooter I also obtain this error:

Error: New configuration files for the Apache web server were not created due to the errors in configuration templates: Syntax error on line 26 of /etc/httpd/conf/plesk.conf.d/server.conf: The address or port is invalid. Search in KB​

Any help on how to resolve this issue and how can I add IPv6 addresses? Don't want to remove the IPv6 addresses that are assigned to the domains in case they couldn't be added later
 
Sorry. I have no problem on deleting the IP 0.0.0.0 from the panel. When I Reread the IPs then it's newly inserted. So the problem must be at some other config.
 
Finally they resolved. Problem was that at some time Plesk setup an IPv6 with Scope Global ( /0 instead of /64 ). Once it was fixed with the right netmask everything turned to go fine as I could check.
Thanks.
 
Back
Top