1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

SpamAssassin not enabled in mailboxes

Discussion in 'Plesk for Linux - 8.x and Older' started by timgdixon, May 4, 2006.

  1. timgdixon

    timgdixon Guest

    0
     
    I had SpamAssassin installed today as part of a package (I also have the issue of the Application Vault showing all apps require php4 and i have php5 and I am waiting on help from the provisioner for that but thought i could ask this in the meantime) and although it is visible in the Server control panel, (i have it set server wide & personal settings as suggested in the help file) and enabled, it is off in all user mailboxes in every domain installed. Also the Spam Filter icon in user mailboxes is greyed out as well.

    Do i have something set wrong?

    Plesk version psa v8.0.0_build80060331.13 os_FedoraCore 4
    Operating system Linux 2.6.11-1.1369_FC4smp

    I admit I am very new to this Plesk desktop and could use any help you can give me. Thank you.

    Tim
     
  2. poke

    poke Guest

    0
     
    first off look at your license page and confirm you can use psa-spamassassin as it could be installed but greyed out due to license restrictions...

    -Richard
     
  3. timgdixon

    timgdixon Guest

    0
     
    Thank you for the reply. Yes it is turned on. This is a 100 domain license that came with the Application Pack. As a side none of the applications will install because of some issue between the server having php5 and the app's requiring php4. But thats for another thread, unless it has some bearing on this.

    License:
    Ability to use SpamAssassin On
     
  4. timgdixon

    timgdixon Guest

    0
     
    Richard I just noticed that when i added a new mailbox the Spam Filter option was available. When it completed Spam Assassin was available as was Spam Filter so I may have answered my own question.

    Unfortunately it looks like I will have to delete all boxes and reinstall them to get it to work. Unless you know of any other options.
     
  5. vonaras

    vonaras Guest

    0
     
    You can turn on Spamassassin on individual mailboxes by "checking" the mailbox and choosing "Group Operations".
     
  6. phatPhrog

    phatPhrog Guest

    0
     
    Shame there isn't a global command to change all email accounts on the server, huh?
     
  7. phoenixisp

    phoenixisp Silver Pleskian

    27
    57%
    Joined:
    Feb 2, 2002
    Messages:
    840
    Likes Received:
    0
    There is, you can use the mchk utility.

    Simply run:

    /usr/local/psa/admin/bin/mchk --with-spam

    This should activate Spamassassin on all mailboxes.
     
  8. dprophit

    dprophit Guest

    0
     
    Other options?

    What all options will mchk allow? We have to manually go back and and turn on virus checking in and out and spam.
     
  9. dprophit

    dprophit Guest

    0
     
    How about mchk other options? Can dr web be turned on too? We have to manually set it for incoming/outgoing
     
Loading...