1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

SpamAssassin Not Working

Discussion in 'Plesk for Windows - 8.x and Older' started by rmmoore80, May 23, 2005.

  1. rmmoore80

    rmmoore80 Guest

    0
     
    My Windows 7.5.x installation's SpamAssassin is not flagging anything at all. I trained the box with about 3,000 spam AND 3,000 NonSpam, yet it still doesn't work. Where should I start looking next? The SpamAsassin website is terrible...so that didn't help. Anyone suggestions? The plesk control panel SEEMS to interact with it fine, but mail doesn't pass through SpamAssassin.
     
  2. wharfratjoe

    wharfratjoe Guest

    0
     
    I manually added .cf files to my SpamAssassin with rules i found on the internet. I have not trained it all. the rules i found catch close to 99% of spam.
     
  3. rmmoore80

    rmmoore80 Guest

    0
     
    Where can I find those rules at, or could you perhaps email them to me so I can give it a shot?
     
  4. sieb@

    sieb@ Guest

    0
     
    check the logs for the MTA in Mailenable, make sure the mail pickup event is working (meaning its sending incoming mail through SA)..
     
  5. rmmoore80

    rmmoore80 Guest

    0
     
    Thanks, I will do that. I found a cf rules website and added a few, still nothing.
     
  6. rmmoore80

    rmmoore80 Guest

    0
     
    The MTA Activity logs do not contain anything about SpamAssassin in any of my logs for the past two months.

    I also checked the SMTP logs, and the MTA Debug logs. The word spam only shows up once in someone's email address, other than that nothing.

    Any suggestions on where to look next? How do I tell MailEnable to send through SpamAssassin first?
     
  7. lboss

    lboss Guest

    0
     
    Make the following steps:
    1. run cmd.exe
    2. cd "%plesk_dir%\Additional\SpamAssassin"
    3. nmake
    4. nmake install
    5. perl makefile.pl CONTACT_ADDRESS="customer-service@sw-soft.com"

    It is creation spamassassin config files.

    To check mailenable configuration:
    1. Open Start\All Programs\Mail Enable\MailEnable Administrator
    2. Open properties of MailEnable\Mail Enable Management\Servers\Agents\MTA
    3. Check Enable pickup event
    4. "Program to execute on mail file" usually is C:\Program Files\SWsoft\Plesk\admin\bin\memailfilter.exe
     
  8. rmmoore80

    rmmoore80 Guest

    0
     
    I did what you suggested. The setting was set properly also.

    Is there any way i can run a test to see if it's working now? Don't want to wait until I get spammed.
     
  9. rmmoore80

    rmmoore80 Guest

    0
     
    EventViewer is showing this:

    System.Exception: SpamAssassin daemon for server wide settings is not running.
    at SpamAssassinService.FilterThread.filterMessage(String fileName, String mailName, Boolean checkOnly, Boolean userOnly, SpamResult& spam)
    at SpamAssassinService.FilterThread.threadProc()

    Suggestions? The Plesk SpamAssassinService is running, succesfully.
     
  10. rmmoore80

    rmmoore80 Guest

    0
     
    This problem has been fixed. It was as simple as uninstalling and reinstalling SpamAssassin using the 7.5.3 Installer.
     
  11. atinoco

    atinoco Guest

    0
     
    where should we place the .cf files (custom rules)

    i copied some of SARE custom rules, to "C:\Program Files\SWsoft\Plesk\Additional\SpamAssassin\rules" but SA doesn't seem to be using then, can anybody help me please, I can't find any docs on custom .cf rules on SA for windows.

    Thanks in Advance
     
  12. wharfratjoe

    wharfratjoe Guest

    0
     
    atinoco,

    Place your customer SA rules here:

    1.%plesk_dir%\Additional\Perl\site\share\spamassassin
    2.On my custom rules i put a 10_ infront of the custom .cf file so it reads it first.
    3.Then I manually restart the spamassassin service for it to kick in.

    Hope that helps
    joe
     
  13. atinoco

    atinoco Guest

    0
     
    Figured it out late last night also, ty for the info anyways my friend.

    For the record:

    I tried 1st placing the rules in the path "C:\Program Files\SWsoft\Plesk\Additional\Perl\site\etc\mail\spamassassin" and they didn't seem to work, then I placed them in "C:\Program Files\SWsoft\Plesk\Additional\Perl\site\share\spamassassin" and they finally worked.
     
  14. wharfratjoe

    wharfratjoe Guest

    0
     
    cool. glad you got it working :)
     
Loading...