1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Squirrelmail in Plesk 8

Discussion in 'Plesk for Linux - 8.x and Older' started by TXRanger, Apr 8, 2008.

  1. TXRanger

    TXRanger Guest

    0
     
    Our older Plesk servers used to come pre-configured to use Horde with webmail.domain.com and to use Squirrelmail with domain.com/webmail. I notice with Plesk 8, Horde still exists, but SquirrelMail does not. As we begin to migrate domains from our old Plesk servers to our new Plesk servers the most common request we get is to "fix" it so that squirrelmail works with domain.com/webmail.

    How can we install Squirrelmail on our new Plesk servers so that it is accessible to our users through domain.com/webmail (like the older 7.x Plesk) without breaking Horde (or anything else)?
     
  2. jwdick

    jwdick Guest

    0
     
    On our boxes ( CentOS4 with Plesk8.3 ) we installed Squirrelmail from the CentOS repos with: #yum install squirrelmail

    Then:
    edit /etc/httpd/conf.d/squirrelmail.conf for this:

    Alias /webmail /usr/share/squirrelmail
    Alias /squirrelmail /usr/share/squirrelmail
    <Directory /usr/share/squirrelmail>
    Options Indexes
    AllowOverride none
    DirectoryIndex index.php
    Order allow,deny
    allow from all
    </Directory>


    Next:

    Set in /usr/share/squirrelmail/config/config.php
    for the following ( options set in /usr/share/squirrelmail/config/conf.pl )

    $imap_server_type = 'courier';
    $optional_delimiter = '.';

    $default_folder_prefix = 'mail/';
    $trash_folder = 'INBOX.Trash';
    $sent_folder = 'INBOX.Sent';
    $draft_folder = 'INBOX.Drafts';


    After the above, domain.tld/webmail would open Squirrelmail and horde still was webmail.domain.tld

    That's what worked for us.
     
  3. TXRanger

    TXRanger Guest

    0
     
    Well, I took a chance and just instlled SquirrelMail from the RPM, and it pretty much worked. I am running Plesk 8.3 on RHEL5. So here is what I did:
    yum install squirrelmail

    It installed without errors, so I tried www.domain.com/webmail, but it didn't work (404). So then I went to create a new configuration file for it (to create the "webmail" alias) in /etc/httpd/conf.d, but I noticed that there was already a "squirrelmail.conf" file there. The contents already contained the following line:
    Alias /webmail /usr/share/squirrelmail

    With this alias, I figured I would have gotten something besides a 404, so I restarted Apache, and then tried www.domain.com/webmail
    And it worked up to the login screen. After logging in, I got an error about apache not having write access to a file "Error opening /var/lib/squirrelmail/prefs/default_pref". This turned out to be a PHP "safe mode" issue and was resolved by editing the /etc/httpd/conf.d/squirrelmail and adding the following:
    <Directory /usr/share/squirrelmail>
    php_admin_value safe_mode off
    </Directory>

    Then I got a little bit further but after logging in got "Query: CREATE "Sent"
    Reason Given: Invalid mailbox name." At this point, I realized that jwdick had replied to my post, so I implemented his 6 changes to the /etc/squirrelmail/config.php and now it seems to be working fine without any errors.
     
Loading...