1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Ssi Problems... Still

Discussion in 'Plesk for Linux - 8.x and Older' started by lordnahkim, Oct 11, 2005.

  1. lordnahkim

    lordnahkim Guest

    0
     
    PLEASE HELP!!

    After digging through scores of threads, docs and tutorials I still can't seem to get an standard shtml include to work on my server. I have edited the httpd.conf at the root etc. and have tried creating vhost.conf at the domain, htaccess at the domain. I have tried everything I've seen but to no avail. I think I have learned that the default installation od fedora has includes disabled in the httpd.conf and plesk creates an override for each domain when you enable it through PSA. So if this is the case, I don't know what I am missing. Does the SSI in Plesk refer to something else? Some other file extension? I am not an expert in any of this all I want is the ability to execute another type of ssi aside from turning everything to PHP. I do admit editing the httpd.conf for the entire server was confusing to me. The directive statements may need to be redundant? Maybe I put them in the wrong place? Please help! Thank you so much.
     
  2. webrebel

    webrebel Guest

    0
     
    I had the same problem and my solution was to just put a .htaccess file with the following in it in EACH directory I wanted to use SSI:

    AddType text/html .shtml
    AddHandler server-parsed .html
    AddHandler server-parsed .htm
    AddHandler server-parsed .shtml
    Options Indexes FollowSymLinks Includes

    I'm not sure you can set it serverwide with Plesk. At least I couldn't figure it out.

    edit: just add the lines above to any existing .htaccess file, do not overwrite existing file
     
  3. lordnahkim

    lordnahkim Guest

    0
     
    close...

    Thanks for that! I was able to at least get an error that brought me closer to the solution:

    [an error occurred while processing this directive]

    I may have reverted some things in httpd.conf since my initial attempts. Maybe I just need to make one more tweak somewhere?

    Thanks again for your time
     
  4. webrebel

    webrebel Guest

    0
     
    That tells me SSI is parsing, probably a setting in the SSI call itself needs looked at.

    Try some thing simple like
    <!--#echo var="DATE_LOCAL" -->
    add that to the webpage and see if it parses, if so then look at the script settings you are using.

    cheers, Mike
     
  5. lordnahkim

    lordnahkim Guest

    0
     
    Date_Local worked

    webrebel, you are more helpful than my hosting provider! So the date_local ssi worked fine. The shtml files are still not parsing. I still get the error: [an error occurred while processing this directive]

    Here is an example of the ssi call that I am trying to use:
    <!--#include file="../global-ssi/top-nav.shtml" -->

    I tried the full file path too and got the same error. Maybe there is a setting wrong in my global directives?
     
  6. webrebel

    webrebel Guest

    0
     
    If the date call worked then SSI is working.

    Try it without the 2 dots in front of /global

    <!--#include file="/global-ssi/top-nav.shtml" -->

    BTW, you can use .htm, .html extentensions and SSI will still parse using the .htaccess file above, no need for the .shtml extension
     
  7. lordnahkim

    lordnahkim Guest

    0
     
    I really think it is something else...

    I've tried a dozen variances with folder paths, permissions, etc. I think the problem must be something with the main httpd.conf or overrides aren't allowed. Thanks again for taking the time to try and help. That is very generous of you. I'll keep on it.
     
  8. webrebel

    webrebel Guest

    0
     
    ooops.. I forgot you should use the virtual argument if the file is outside the root. Try:

    <!--#include virtual="/global-ssi/top-nav.shtml" -->
     
  9. lordnahkim

    lordnahkim Guest

    0
     
    YAY!!!

    That did it Mike!! Much appreciated - all the best to ya
     
  10. madsere

    madsere Regular Pleskian

    26
    57%
    Joined:
    May 8, 2005
    Messages:
    200
    Likes Received:
    0
    Yes, it seems with 7.5.4 whether you tick SSI or not the necessary "Options Includes" are never actually added to any of Apaches config files.

    Just create a vhost.conf or something like that under /home/httpd/vhosts/(site)/conf and include the line "Options +Includes" and it should work. Remember to restart Apache.

    Amazing with the price of Plesk they can't even sort an obvious and simple bug like this out by themselves.

    I'm really beginning to regret moving from Ensim to Plesk. Should probably have moved to Cpanel instead. May still do.

    Grrr!
     
Loading...