1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

SSL certificate is not working. Shared IP issue?

Discussion in 'Plesk for Windows - 8.x and Older' started by arqadia, Sep 18, 2009.

  1. arqadia

    arqadia Guest

    0
     
    Hi

    We have 2 domains running on a single IP. We use Plesk 8.1.1 and VPS.
    We had a SSL certificate that recently expired on one domain, so I ordered another one and installed it to the domain according to the instructions.
    But the web site still shows the old certificate, and hence, gives security warnings to browsers, as the certificate has expired.
    On the installation notes for installing the Certificate via Plesk, it mentions that if you are on shared hosting (a shared IP) then the certificate will not work because SSL requires a single IP, but the certificate HAS been working for a year, I just can't work out how.
    Shared SSL is enabled and I've left the settings exactly as they were.

    Can anyone shed any light on this problem?

    Thanks
     
  2. arqadia

    arqadia Guest

    0
     
    Fixed it!

    OK, after 2 days of messing about, calls and e-mails to the ISP and Comodo, I fixed it myself with the help of another thread on this forum.

    Here was my solution:
    From the plesk control panel
    Clients>my name>IP Pool>IP address>Choose certificate.
    The certificate selected in the drop down list looked like the right one but it said 'Administrators repository' but there was another entry in the dropdown list which I knew was the correct one ('Domain repository') so I chose that one instead and now all is working!

    Yippee!! I can stop banging my head against the wall!
     
Loading...