1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

SSL certificate not updating, not uploading, interim SSL cert remains

Discussion in 'Plesk for Linux - 8.x and Older' started by axxs, Mar 3, 2008.

  1. axxs

    axxs Guest

    0
     
    I migrated a site from Plesk8.2 on a server to another server Plesk 8.3

    I removed the original certificate after the move as it was almost up anyway.

    I setup a domain with a new rapidSSL cert in it's certificates section (I've done this plenty of times b4 on 8.2 being the only difference)

    In Plesk, under IP Addresses, clicking on the IP it shows the certificate as chosen for the exclusive IP.

    Under the domain, 'Setup' it shows the certificate as chosen.

    Under domain, certificates, it shows the cert as being used (1)

    But when going to the site https, I get host.domainname.com SomeOrganisation SomeOrganisationUnit.

    I have stopped and started apache (not just reloaded) using websrvmng no luck, I have restarted psa from the command line too, no luck

    I have re-added the rapidssl CA cert, no luck.

    I removed the certificate from the system completely after backing it up (downloading via the disk icon).

    Stop/start (not restart or just reload) apache and psa.

    STILL has the same cert response, even after removing the cert so ONLY default cert exists in Plesk.

    Trying to upload the certificate again results in :

    Error: Unable to find the appropriate private key for the certificate.

    but the private key seem to be in the file.

    Anyone come across this? for all intensive purposes the cert is setup in plesk, but it's serving some interim self-signed cert instead. I'm lost as to what to try next :(
     
  2. axxs

    axxs Guest

    0
     
    the only certificate in plesk atm is the default certificate.

    stopped, then started apache, and psa for good measure.

    I still get the host.domainname.com cert. different from the default cert.

    I edited the httpd.include file, and added to the cert file mentioned by the apache handler SSLCertificateFile PATHNAME, the certificate contents from the certificate.

    stopped, then started again, the apache service.

    I still get the host.domainname.com interim cert response.

    just doesn't make sense at all
     
  3. axxs

    axxs Guest

    0
     
    I changed the IP under setup for the domain to the other IP on the box, clicked save, then changed it back.

    viola, now it's working.

    Tho I used to have the exclusive IP serving content accessible via the direct IP, now it's just the Plesk default page, and if I set the domain as the default for the IP in Plesks IP settings (it's the only choice anyway), it shows on the IP, but reverts to the issue .. go figure
     
Loading...