1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

SSL / Hostname issue after upgrade to Plesk 11

Discussion in 'Plesk 11.x for Linux' started by FirstPoint, Oct 18, 2012.

  1. FirstPoint

    FirstPoint Basic Pleskian

    17
    85%
    Joined:
    Feb 8, 2011
    Messages:
    37
    Likes Received:
    0
    Hi all,

    We just upgraded to Plesk 11 and got a small issue since then.
    Before, on Plesk 10, when we would go to http://srv1.hostname.com:8443, we would directly get to the login page of Plesk. Sice we upgraded, when we go to the same URL, it first redirects to http://nsXXXXX.ovh.com (our server is at the OVH datacenter, this is the default hostname), gives an SSL error (of course, since the SSL certificate is made for our domain). When we accept the SSL certificate, it then redirects to our domaine... However, the panel URL is well configured, the hostname of the server also, and the reverse aswell...

    Any help will be greatly appreciated, thanks !
     
  2. Nikolay.

    Nikolay. Silver Pleskian

    17
    35%
    Joined:
    Jul 1, 2012
    Messages:
    844
    Likes Received:
    2
  3. FirstPoint

    FirstPoint Basic Pleskian

    17
    85%
    Joined:
    Feb 8, 2011
    Messages:
    37
    Likes Received:
    0
    Sorry, that was a typo. We're of course using httpS :) Same problem with 8880
     
  4. abdi

    abdi Platinum Pleskian

    31
    18%
    Joined:
    May 14, 2006
    Messages:
    2,913
    Likes Received:
    60
    This should solve your problem ...

    vim /usr/local/psa/admin/conf/ssl-conf.sh

    Change:

    Code:
    echo 'ssl.engine = "enable"'
    to

    Code:
    echo 'ssl.engine = "disable"'
    then finely,

    /etc/init.d/psa restart
     
  5. FirstPoint

    FirstPoint Basic Pleskian

    17
    85%
    Joined:
    Feb 8, 2011
    Messages:
    37
    Likes Received:
    0
    That did not fix the issue... It just stays stuck when getting to nsXXX.ovh.com.
    I don't see why disable SSL engine would fix the issue ?
     
  6. abdi

    abdi Platinum Pleskian

    31
    18%
    Joined:
    May 14, 2006
    Messages:
    2,913
    Likes Received:
    60
    I suggested that because there is no way you can access plesk on "http://" as stated in your first post without having SSL disabled ...

    Infact if SSL is not disabled, by default it would redirect you to the https://hostname.com:8443/ If you already have a valid SSL certificate installed then make sure its enabled as the default SSL for the panel. You do that from Tools and Settings -> SSL certificate.
     
  7. FirstPoint

    FirstPoint Basic Pleskian

    17
    85%
    Joined:
    Feb 8, 2011
    Messages:
    37
    Likes Received:
    0
    abdi, thanks for your answer. However, as stated in my second post, i had made a typo in my first post and we were actually accessing via http, not https.

    We managed to fix the issue by running:

    update psa.misc set val='https://plesk.domainame.com:8843' where param='sso_relay';

    update psa.misc set val='https://plesk.domainame.com:8843' where param='sso_server';

    update psa.misc set val='https://plesk.domainame.com:8843' where param='sso_server_user_url';
     
  8. Nikolay.

    Nikolay. Silver Pleskian

    17
    35%
    Joined:
    Jul 1, 2012
    Messages:
    844
    Likes Received:
    2
    So it's an SSO integration issue then?

    Can you share the old values for these parameters? Were they pointing to http://nsxxxxx.ovh.com/ ?
     
  9. FirstPoint

    FirstPoint Basic Pleskian

    17
    85%
    Joined:
    Feb 8, 2011
    Messages:
    37
    Likes Received:
    0
    Yes they were pointing to the old hostname. Quite wired because appearently these values where there for at least one year, but before the upgrade to PSA 11, didn't cause any problem.
     
  10. abdi

    abdi Platinum Pleskian

    31
    18%
    Joined:
    May 14, 2006
    Messages:
    2,913
    Likes Received:
    60
    Alright, sometimes this also resolves that problem:

    /usr/local/psa/bin/sso --disable
     
  11. Nikolay.

    Nikolay. Silver Pleskian

    17
    35%
    Joined:
    Jul 1, 2012
    Messages:
    844
    Likes Received:
    2
    Provided you don't have CBM (Billing).
     
  12. abdi

    abdi Platinum Pleskian

    31
    18%
    Joined:
    May 14, 2006
    Messages:
    2,913
    Likes Received:
    60
    That's right Nikolay thanks for pointing that out ...
     
Loading...