1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

SSL httpsd and plesk

Discussion in 'Plesk for Linux - 8.x and Older' started by agentgeek, Aug 14, 2005.

  1. agentgeek

    agentgeek Guest

    0
     
    Ok,

    So I have combed the forum and found lots of things that don't work.

    Here is my problem. I have setup my server and everything except SSL will work. The Plesk interface and webmin both work fine on their respective ports https:...:8443 and :10000. BUT any domain I add and check the box for ssl support does not work on https. I have tried everything I know(and I am definately not a linux newbie)-- I just can't get it to work.

    If I do a ps -aux | grep httpsd I get multiple pids...normal since it is running for plesk, etc. If I do a netstat -l nothing is listening on :https(443). If I do a /etc/rc.d/init.d/psa restart, apache restarts fine with no errors. If I do an apachectl restart I get lots of errors complaining that all the IP addresses:443 do not have names, etc.

    What gives?
    I have been beating my head against the wall on this, spending a lot of time I really don't have, and not getting anywhere.

    If you have any input on this...any at all, please please respond. I'll be checking this thread several times a day from work and home.

    Thanks in advance

    AgentGeek
     
  2. jamesyeeoc

    jamesyeeoc Guest

    0
     
    From your reported error "all the IP addresses:443 do not have names", I would check the following.

    In the /etc/httpd/conf/httpd.include file, check to make sure you have sections such as:

    for each of the IPs on the server. The 'ip.ad.dr.ess' would be replaced by your IP(s).
     
  3. agentgeek

    agentgeek Guest

    0
     
     
  4. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
    is something else listening on 443? The default behavior of apache on the rpm distros (redhat/fedora/suse/mandrake/centos) is to listen on 443. Try shutting httpd down and telneting to port 443.
     
  5. agentgeek

    agentgeek Guest

    0
     
    Ok,

    This has been figured out. The problem seems to be that the ssl.conf file was screwed up. Reinstalling (-Uvh) the mod_ssl rpm fixed it.


    Peace on you all :)

    :wq
     
Loading...