1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

SSL woes

Discussion in 'Plesk for Linux - 8.x and Older' started by michaellunsford, Aug 28, 2006.

  1. michaellunsford

    michaellunsford Regular Pleskian

    25
    90%
    Joined:
    Jul 25, 2005
    Messages:
    131
    Likes Received:
    0
    I have an SSL certificate configured on a server. When I visit the :8443 (plesk port) I get the right certificate, but visiting plain old port 443 still presents the self signed.

    Here's what I've done so far:
    1. had plesk create the CSR. I pasted in the cert and CA.
    2. I checked the new cert and clicked the "setup" button, rechecked and clicked the "default" button.
    3. under server > ip address, I made the appropriate domain the default domain. I also specified the new certificate under the IP address.

    What step did I miss?

    PS> this is running on a Virtuozzo VPS, if that matters. When I visit the Virtuozzo port (4643), I get yet another certificate, which looks like the ISP's cert.

    EDIT: I have deleted all other certificates from the server and domain control pannels. There is one certificate in plesk -- yet port 443 continues to issue the mystery self-signed certificate.

    vhosts/example.com/conf/httpd.include is calling the right cert. Something is apparently overriding this setting.
     
Loading...