1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Still having problems running scripts

Discussion in 'Plesk for Windows - 8.x and Older' started by colinjack, Jan 6, 2006.

  1. colinjack

    colinjack Guest

    0
     
    We are runniing 7.5.6 on Server 2003

    As a rule we recommend that all scripts (php, pl, cgi etc) are run from clients' /cgi-bin. Unfortunately some clients report that when running PHP scripts they get a login dialog - not all clients have this problem, but most. Permissions all look fine etc. (read/execute)

    We have posted this before but not had a resolution. Anybody any ideas?

    :confused:
     
  2. colinjack

    colinjack Guest

    0
     
    Even more bizarre is that if I set PHP to run as an ISAPI extension then it effectively 'kills' the site (browser returns blank pages for .html) ... but the .php script doesn't return a login dialog.

    Weird - especially as not all sites are affected (although most)
     
  3. good2go@

    good2go@ Guest

    0
     
    did you ever find a resolution for this?

    Aaron
     
  4. colinjack

    colinjack Guest

    0
     
    No ... I am still trying to get around it. It has something to do with the way Plesk applies the permissions, but even setting them manually hasn't sorted it. Odd.
     
  5. good2go@

    good2go@ Guest

    0
     
    well i figured it out on my server so hopefully its the same for you. Go to your perl directory (mine is program files/plesk/additional/perl I think)... check the perms on that folder. Chances are if you have the same problem as me, you need to add the IUSR group to it, just needs read execute and you should be in business. Hopefully you have the same problem as I did.


    Aaron
     
  6. colinjack

    colinjack Guest

    0
     
    Aaron you bloomin' star :D

    I have been looking in totally the wrong area - checking folder permissions etc. Didn't for a minute think Plesk would be dim enough to not allow the IUSR group execute permissions to the progs in the additionals. Doh!

    Well done.

    Colin
     
  7. OlegB

    OlegB Guest

    0
     
    Plesk grants access permission on Additional folder be default and they can't be reset by Plesk. Only manually.

    But you can restore default Plesk permission on all Plesk folders using Plesk reconfigurator.
     
  8. colinjack

    colinjack Guest

    0
     
    I had already tried the reconfigurator and it hadn't fixed it. I have been battling with this problem for months and nobody from Plesk even suggested checking this.
     
  9. good2go@

    good2go@ Guest

    0
     
    Yeah Oleg, your reconfigurator didnt fix the problem for us either... perhaps something else to check for a future revision.

    Glad to hear it worked for ya colin

    Aaron
     
  10. colinjack

    colinjack Guest

    0
     
    ... and thank you :D
     
Loading...