1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Subdomains not working with domains containing wildcard

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by TomBeh, Dec 1, 2011.

  1. TomBeh

    TomBeh New Pleskian

    12
    60%
    Joined:
    Dec 1, 2011
    Messages:
    3
    Likes Received:
    0
    I've migrated from 9.x to a 10.4.4 server, and have the following problem.

    I have a domain with a wildcard, CNAMED to an application server elsewhere. *.example.com CNAME live.app.com

    Originally the subdomains were A records in the single DNS zone. The problem is that now subdomains have their own DNS zone, the wildcard in the primary zone's master domain takes precedence. And I can't add the subdomain to the main DNS zone as it conflicts.

    All the other solutions I can find to this are to do with ordering domains for catch all using Apache Vhost ordering, not using a wildcard DNS record. The apache solution won't work here as the wildcard domain (lower priority than subdomains) is hosted on a different server.

    Any way around this? I'm almost at the point of giving up and moving the affected subdomains to another domain that doesn't have a wildcard. But that's going to cause lots of problems and work in itself. Is there a way back to the original single zone method for this domain?
     
  2. HernanR

    HernanR Guest

    0
     
    Last edited by a moderator: Dec 1, 2011
  3. Sergey L

    Sergey L Golden Pleskian Staff Member

    32
    43%
    Joined:
    Aug 10, 2006
    Messages:
    1,195
    Likes Received:
    30
    10.4 has native support for wildcard subdomains. You can try it as a solution.
     
Loading...