• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

support user+extension@domain style addresses using postfix

AubreyH

New Pleskian
Hi,

I would like to support user+extension@domain addresses [user+extension@domain -> user@domain] (using postfix through plesk).

We have set:
main.cf
Code:
recipient_delimiter = +

master.cf (on the maildrop config):
Code:
-d ${user}@${domain} ${extension} ${recipient} ${user} ${nexthop}
@see http://www.postfix.org/MAILDROP_README.html
@see http://superuser.com/questions/587458/postfix-unlimited-per-user-addresses-via-sign

Though it still fails and the error log (mail.err) says:
Code:
DATE HOST postfix-local[PID]: Unknown user: USER+ETC@DOMAIN
I know that the directory name "USER+ETC" is being looked for.. and yeah it does not exist... so all current settings seem to be ignored. Something is still looking for "USER+ETC" as a delivery directory. I am assuming that the maildrop is not used as plesk has its own "plesk_virtual"...
Is it something that needs to be changed on the master.cf "plesk_virtual" config? If I add the same -d option to the "plesk_virtual" config; all mail fails with "Local delivery is disabled due to server misconfigurations"

Am I missing something? How can I support user+etc@domain addresses using a plesk/postfix combo?

Thanks, Aubrey

p.s. Sorry if question has already been answered (I could not find it).. s-)
 
Back
Top