• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

sw-cp-server errors

E

EdwardDekker

Guest
I have found some problems into plesk server 10.4.4

OS Centos 5.7
PSA 10.4.4 - cos5.build1013111102.18.i386

$ /var/log/sw-cp-server/error_log

Code:
PHP Warning: json_encode() [<a href='function.json-encode'>function.json-encode</a>]: Invalid UTF-8 sequence in argument; File: /usr/local/psa/admin/plib/Zend/Json.php, Line: 146

Exception: PHP Warning: json_encode() [<a href='function.json-encode'>function.json-encode</a>]: Invalid UTF-8 sequence in argument; File: /usr/local/psa/admin/plib/Zend/Json.php, Line: 146

file: /usr/local/psa/admin/smb/application/library/Smb/Exception/Syntax.php
line: 55
code: 0
trace: #0 [internal function]: Smb_Exception_Syntax::handleError(2, 'json_encode() [...', '/usr/local/psa/...', 146, Array)
#1 /usr/local/psa/admin/plib/Zend/Json.php(146): json_encode(Array)
#2 /usr/local/psa/admin/panel/application/controllers/ServerController.php(29): Zend_Json::encode(Array)
#3 /usr/local/psa/admin/plib/Zend/Controller/Action.php(513): ServerController->toolsAction()
#4 /usr/local/psa/admin/plib/Zend/Controller/Dispatcher/Standard.php(295): Zend_Controller_Action->dispatch('toolsAction')
#5 /usr/local/psa/admin/plib/Zend/Controller/Front.php(954): Zend_Controller_Dispatcher_Standard->dispatch(Object(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http))
#6 /usr/local/psa/admin/panel/application/library/AdminPanel/Applic
2011-11-24 22:23:02: (mod_fastcgi.c.2588) FastCGI-stderr: ation/Web.php(20): Zend_Controller_Front->dispatch()
#7 /usr/local/psa/admin/panel/application/public/index.php(15): AdminPanel_Application_Web->run()
#8 {main}
 
Try to comment line

default_charset = "UTF-8"

in admin's php.ini.
 
Problem solved for now.

Code:
2011-11-25 09:06:43: (log.c.135) server stopped
2011-11-25 09:06:43: (log.c.75) server started
 
Back
Top