• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

sw-engine fails to start

betteres

New Pleskian
sw-engine fails to start with the following message:

system is debian 7.0.7 with Plesk 12.0.18
I have the problem on two servers, it started after upgrading debian

/usr/bin/sw-engine: error while loading shared libraries: libruntime.so.1: cannot open shared object file: No such file or directory
 
It is installed. Anyway I got fixed. Thank you!
I had to copy the binaries from one location to another.
Even though I edited /etc/ld.so.conf.d/sw_libs.conf and ran ldconfig, plesk would not see them.
 
Back
Top