1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

SW-Soft You have done it again with this Plesk 8.0.1 update

Discussion in 'Plesk for Linux - 8.x and Older' started by phatPhrog, Jun 16, 2006.

  1. phatPhrog

    phatPhrog Guest

    0
     
    Cheers to you guys once more for releasing updates prematurely!!!!

    Although Plesk is the best system available, you guys really know how to f *** up a good thing!

    My partner just ran an update via one of our Plesk servers.....since updates were available for 8.0.1.

    Not knowing the havoc he would create, he chose to update the 8.0.1 and on his return to complete the update he finds, (as well as I find)
    WHAT ARE YOU GUYS DOING TO US?

    No UPDATE link is available anymore!!!

    One day you are updating to 8.0.1 then next thing we know you are waiting until the autumn to do so, then WTF, you spring it on us and screw everything up!

    Don't you make enough money to pay troubleshooters, or perhaps programmers to verify these upgrades?

    Now I have to reimage our servers, thus bringing down client accounts. Shees! You guys really **** sometimes!
     
  2. CruzMark

    CruzMark Basic Pleskian

    24
    23%
    Joined:
    Mar 6, 2006
    Messages:
    84
    Likes Received:
    0
    For what it's worth, I've not run the update at all and my updater says exactly the same thing...

    Oh, and I learned my lesson long ago. Never update *anything* on a Friday unless you're ready to work over the weekend...
     
  3. DazTomkins

    DazTomkins Guest

    0
     
    Im also having problems updating to 8.0.1. i get the following error:

    ERROR: PleskFatalException
    Undefined release.

    --------------------------------------------------------------------------------

    0: /usr/local/psa/admin/plib/common_func.php3:169
    psaerror(string 'Undefined release.')
    1: /usr/local/psa/admin/htdocs/server/autoinstaller_install.php:15


    :mad:
     
  4. MiLor

    MiLor Guest

    0
     
    Here the same


    My first PLESK server, others are WHM/CPanel no problems over there.
     
  5. RuthServer

    RuthServer Guest

    0
     
    hi,

    "Warning: Error: There is no release with ID PLESK_8_0_0."

    where does this message appear?
     
  6. mhutchings

    mhutchings Guest

    0
     
    Just out of curiosity, what OS / Version is everyone using that is having problems.

    I updated multiple servers without any problems. Most of our companies servers are Fedora Core 4 servers.
     
  7. jens.jensen

    jens.jensen Guest

    0
     
    FC4 (smp, 64-bit)

    I had a similar problem where the update appeared to start but never did anything (it did successfully kill apache) and did not notify me of it.

    logged in ssh as root and ran plesk autoinstaller (? /usr/local/psa/admin/autoinstaller) and found that it was using /root/psa to store temp files/packages, etc and needed at least 300-400 mb free, which the partition where my /root is did not have enough space. With the autoinstaller I was able to specify a location on a bigger partition. (HEY PLESK, EITHER CHECK TO SEE IF YOU HAVE ENOUGH SPACE OR GIVE THE USER AN OPTION TO USE A TEMP FOLDER ELSEWHERE, and please, please notify us if it failed.!)


    So advice would be, attempt running autoinstaller as root and maybe you will get more info on why the update failed.
     
  8. DazTomkins

    DazTomkins Guest

    0
     
    Hi, Im also using Fedora Core 4.

    Ive tried running the autoinstaller through root on ssh and it seemed to go ok, downloaded all the files etc, was about to install them, and then it said


    So, can i ask which directory you changed yours to, and how you changed it?

    Thanks

    Daz
     
  9. DazTomkins

    DazTomkins Guest

    0
     
    Well i found out how to change the directory, so ive changed it to a directory which has like 50 Gb of free space.

    It proceeds to download the files into this directory, but then I get the same error message that i mentioned in my previous post....

    Im confused! :confused:
     
  10. jens.jensen

    jens.jensen Guest

    0
     
    you need to have enough space in two places.

    1. whatever directory the autoinstaller downloads packages to store (defaults to /root/psa) - you can change this in autoinstaller

    2. location of your psa directory (maybe /usr/local/psa, etc) .. If the partition that your /usr directory is on doesnt have enough space to install the updated packages to, then it will likely fail
     
  11. DazTomkins

    DazTomkins Guest

    0
     
    OK, Ive already changed the first, so how do i get round the second problem?
     
  12. jens.jensen

    jens.jensen Guest

    0
     
    well the location that psa and other programs that use the /usr directory are pretty much fixed.

    You would want to look at cleaning up that partition to make room.
    The other option would be to move some partitions around, resize, or repartion some things... that's beyond the scope of this thread
     
  13. phatPhrog

    phatPhrog Guest

    0
     
    Well, since SW-Soft appeared to have fixed the problem, we tried another update.

    This time we received:

    ERROR: error while executing RPM

    What gets me is that it failed because we have a newer version of Spamassassin running on our server.

    spamassassin >= 3.0.0 is needed by psa-spamassassin-8.0.1-fc4.build80060613.20.i586

    Shees! Not gonna sacrifice removal of our SPAM settings to satisfy flaws in the Plesk installer.

    Hope you guys get this worked out.
     
  14. DazTomkins

    DazTomkins Guest

    0
     
    Yeh im also getting that same error now.

    Although mine seems to fail on the migration manager......
     
  15. NightStorm

    NightStorm Guest

    0
     
    Wish I had taken that route. Over 10,000 emails were used to train our spamassassin spam and ham databases, and since the update, the server load *again* went through the roof (a recap of 8.0.0), and psa-spamassassin started dying randomly. We also could no longer use the Plesk interface to make any changes, as the spammng would fail.
    swsoft has been logged into our server twice now, but has not yet updated the helpdesk ticket, nor have they actually fixed spamassassin (evidenced by the 370 spam emails sitting in my inbox right now).
    We've lost all our settings, all the training, and we have SFA working to actually filter the incoming spam.
    *sigh* At least my cPanel boxes filter their incoming spam...
     
  16. pixeline

    pixeline Guest

    0
     
    personally, since the nightmarish upgrade to 8.0, i have decided to never upgrade plesk again. EVER. if it runs without flaws as such i don't care about new features. At least i intend to stick to this maxim as long as possible.

    hell, after all, i'm still using MS word 97 and i'm happy with it.
     
  17. NightStorm

    NightStorm Guest

    0
     
  18. johnjakob

    johnjakob Guest

    0
     
    Sitebuilder Broke after 8.0.1 install

    This is what I get after upgrading to 8.0.1 from 8.0:

    The file /usr/local/sitebuilder/include/autoprp.php cannot be decoded by this version of the ionCube Loader. If you are the administrator of this site then please install the latest version of the ionCube Loader.

    Anyone else having this issue? Everything else appears to working just fine.
     
  19. Traged1

    Traged1 Guest

    0
     
    We noticed that PLESK stop recognizing our coldfusion server and stated that our coldfusion component was no longer installed, we had to re-install the coldfusion support package to get it working again. Also I have noticed that after the upgrade to PLESK 8.01 we needed to restart the psa-spamassassin service as it was left off by defualt since the upgrading of our spam training databases was not possible. Even though by restarting psa-spamassassin service and it is working now, we can NO LONGER train any new spam or hams using the PLESK interface, it just come back up and tells us: Messages learned: 0 as spam, 0 as non-spam, 0 total. I seem to remeber this issue before and we fixed it by removing all the old spam databases for each email address and then restarted the spamassassin service. Oh ya, also the upgrade overwrote our /etc/proftpd.conf file and our ftp server was slow as heck, a simple restore from backup for this file and a xinetd restart fixed it.

    BTW: We are on RHEL3 ES with PLESK 8.01
     
  20. LiquidSolid

    LiquidSolid Guest

    0
     
    Right, ofcourse I as well had to press that interesting update button and select the newest version available. The good thing is that it updated without any error messages, well only a small one. It can't find a template for Monit.

    So I thought aren't I the lucky one. For as far I can see the system is running as normal. The only change is that i'm missing a lot of icons in my control panel. If I check the component page, it says a lot hasn't been installed, but by checking it myself I see all daemons running and working.

    So SWsoft please bring me back my icons.

    I'm using Debian 3.1 with a 2.6.9-3 SMP kernel w/o modifications.

    If anyone has a solutions for the icons, I would highly appreciate it.
     
Loading...