• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

sw_cp_server

Vadim_Zigula

Basic Pleskian
after plesk upgrade:

Starting sw_cp_server service... not installed
how to install? centos 7.

yum check
Loaded plugins: fastestmirror, replace
plesk-base-12.0.18-cos7.build1200140811.16.x86_64 has missing requires of sw-cp-server >= ('0', '2.0.5', None)
 
Last edited:

Starting sw_cp_server service... failed
tail -f /var/log/sw-cp-server/error_log


2015/01/14 07:52:18 [error] 450#0: *45 open() "/usr/local/psa/admin/htdocs/robots.txt" failed (2: No such file or directory), client: 66.249.75.198, server: , request: "GET /robots.txt HTTP/1.1", host: "airliners.lv:8443"
2015/01/15 10:51:29 [error] 450#0: *921 readv() failed (104: Connection reset by peer) while reading upstream, client: 87.226.115.20, server: , request: "POST /plesk/server/reboot/?_randomId=280055 HTTP/1.1", upstream: "fastcgi://unix:/var/run/sw-engine.sock:", host: "airliners.lv:8443", referrer: "https://airliners.lv:8443/admin/server/tools?context=tools"
2015/01/15 11:12:19 [crit] 450#0: *102 connect() to unix:/var/run/sw-engine.sock failed (2: No such file or directory) while connecting to upstream, client: 87.226.115.20, server: , request: "GET /admin/home?context=home HTTP/1.1", upstream: "fastcgi://unix:/var/run/sw-engine.sock:", host: "airliners.lv:8443", referrer: "https://airliners.lv:8443/left.php3"
2015/01/15 11:12:22 [error] 450#0: *102 directory index of "/usr/local/psa/admin/htdocs/" is forbidden, client: 87.226.115.20, server: , request: "GET / HTTP/1.1", host: "airliners.lv:8443", referrer: "https://airliners.lv:8443/login_up.php3"
2015/01/15 11:25:19 [crit] 17464#0: *6 connect() to unix:/var/run/sw-engine.sock failed (2: No such file or directory) while connecting to upstream, client: 87.226.115.20, server: , request: "GET /login_up.php3 HTTP/1.1", upstream: "fastcgi://unix:/var/run/sw-engine.sock:", host: "airliners.lv:8443", referrer: "https://airliners.lv:8443/"
2015/01/15 18:02:56 [emerg] 366#0: BIO_new_file("/usr/local/psa/admin/conf/httpsd.pem") failed (SSL: error:02001002:system library:fopen:No such file or directory:fopen('/usr/local/psa/admin/conf/httpsd.pem','r') error:2006D080:BIO routines:BIO_new_file:no such file)
2015/01/15 18:03:06 [emerg] 985#0: BIO_new_file("/usr/local/psa/admin/conf/httpsd.pem") failed (SSL: error:02001002:system library:fopen:No such file or directory:fopen('/usr/local/psa/admin/conf/httpsd.pem','r') error:2006D080:BIO routines:BIO_new_file:no such file)
2015/01/15 18:28:17 [emerg] 9082#0: BIO_new_file("/usr/local/psa/admin/conf/httpsd.pem") failed (SSL: error:02001002:system library:fopen:No such file or directory:fopen('/usr/local/psa/admin/conf/httpsd.pem','r') error:2006D080:BIO routines:BIO_new_file:no such file)
2015/01/15 18:30:39 [emerg] 9740#0: BIO_new_file("/usr/local/psa/admin/conf/httpsd.pem") failed (SSL: error:02001002:system library:fopen:No such file or directory:fopen('/usr/local/psa/admin/conf/httpsd.pem','r') error:2006D080:BIO routines:BIO_new_file:no such file)
2015/01/16 07:37:26 [emerg] 17323#0: BIO_new_file("/usr/local/psa/admin/conf/httpsd.pem") failed (SSL: error:02001002:system library:fopen:No such file or directory:fopen('/usr/local/psa/admin/conf/httpsd.pem','r') error:2006D080:BIO routines:BIO_new_file:no such file)
 
when i enter login and password, i receive this:

Unable to load object of type SSLCertificate with id=: SSLCertificate: unable to select: no such row in the table
 
Back
Top