1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Switch from Qmail to Postfix Fails...

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by bluenen, Jul 1, 2012.

  1. bluenen

    bluenen Guest

    0
     
    Hi,

    Running Plesk 9.5.4 on Linux (CentOS 5) and am trying to switch from Qmail to Postfix.

    However when I run the autoinstaller it fails to configure postfix correctly, the follow error message is the only error received during the install, autoinstaller actually continues and completes but postfix does not run after this and I have had to switch back to qmail.

    $ /usr/local/psa/admin/sbin/autoinstaller --select-release-current --install-component postfix

    ....

    Trying to register service xinetd... done
    Trying to reload service syslog... syslogd (pid 2345) is running...
    klogd (pid 2348) is running...
    Reloading syslogd...[ OK ]
    Reloading klogd...[ OK ]
    done
    Configuring Postfix-CourierIMAP Plesk Mail Driver...
    Trying to comment out comsat service record from /etc/xinetd.conf... there is no comsat service record in /etc/xinetd.conf

    ERROR while trying to Empty service name for postfix
    Check the error reason(see log file: ), fix and try again

    Aborting...

    ===> Configuring Courier-IMAP server

    Trying to register service xinetd... done
    Trying to Configure Courier IMAP for Plesk-specific authentication... done
    Trying to restart service courier-imap... couriertcpd (pid 16278 16268 16260 16250) is running...
    Stopping Courier-IMAP server:
    Stopping imap [ OK ]
    Stopping imap-ssl [ OK ]
    Stopping pop3 [ OK ]
    Stopping pop3-ssl [ OK ]

    Starting Courier-IMAP server:
    Starting imapd [ OK ]
    Starting imap-ssl [ OK ]
    Starting pop3 [ OK ]
    Starting pop3-ssl [ OK ]

    done
    Trying to executing mail_restore to synchronize mail server settings and Plesk Database... ==> Checking for: mailsrv_conf_init... ok
    ==> Checking for: mail_mailbox_restore... ok
    ==> Checking for: mailsrv_entities_dump... ok
    ==> Checking for: mail_admin_aliases... ok
    ==> Checking for: mail_auth_dump... ok
    ==> Checking for: mailman_lists_dump... ok
    ==> Checking for: mail_responder_restore... ok
    ==> Checking for: mail_drweb_restore... not exists
    ==> Checking for: mail_kav_restore... not exists
    ==> Checking for: mail_kav8_restore... not exists
    ==> Checking for: mail_spf_restore... ok
    ==> Checking for: mail_dk_restore... ok
    ==> Checking for: mail_grey_restore... ok
    done
    Shutting down postfix: [FAILED]
    Starting postfix: [ OK ]

    ===> Updating crontab...
    Trying to ... done
    Trying to reload service xinetd... xinetd (pid 1030) is running...
    Reloading configuration: [ OK ]
    done
    Trying to stop service qmail... qmail-send (pid 15874) is running...
    Stopping : done
    Trying to unregister service qmail... done
    Trying to stop service sendmail... sendmail is stopped
    done
    Trying to unregister service sendmail... done
    Trying to register service postfix... done
    Trying to start service postfix... Starting postfix: [ OK ]
    done
    ....
     
  2. abdi

    abdi Platinum Pleskian

    31
    18%
    Joined:
    May 14, 2006
    Messages:
    2,913
    Likes Received:
    60
    Alternatively you may run the following command to switch MTA to Postfix:

    /usr/local/psa/admin/sbin/autoinstaller --select-release-current --install-component postfix

    and for switching to Qmail:

    /usr/local/psa/admin/sbin/autoinstaller --select-release-current --install-component qmail
     
  3. bluenen

    bluenen Guest

    0
     
    Read my post again. You will note that I used that exact command, that isnt the issue, the issue is that it fails.
     
Loading...