1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

System error 13 when adding custom rule to Firewall

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by Jose MariaR, Jul 4, 2012.

  1. Jose MariaR

    Jose MariaR New Pleskian

    10
     
    Joined:
    Jul 4, 2012
    Messages:
    2
    Likes Received:
    0
    Hi

    I have Plesk 9.3.0 on a Ubuntu Server 8.04, and I have a trouble when trying to create a custom rule on the firewall configuration. When I try to activate the new configuration I get a "System error 13: Permission denied" error:

    safeact: execve failed for /opt/psa/admin/sbin/modules//firewall/safeact: Permission denied

    System error 13: Permission denied
    proc_close() failed: mktime() [<a href='function.mktime'>function.mktime</a>]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Berlin' for 'CEST/2.0/DST' instead


    What can I do?

    Thanks =)
     
  2. abdi

    abdi Platinum Pleskian

    31
    18%
    Joined:
    May 14, 2006
    Messages:
    2,913
    Likes Received:
    60
    Either:

    1. Go to Tools & Settings -> Time Settings and set your own time zone

    or

    2. Edit the file /usr/local/psa/admin/conf/php.ini and or /etc/php.ini

    and enter the following (Replace Africa/Khartoum with your own)

    date.timezone = Africa/Khartoum
     
  3. Jose MariaR

    Jose MariaR New Pleskian

    10
     
    Joined:
    Jul 4, 2012
    Messages:
    2
    Likes Received:
    0
    Thanks for replaying.

    The time zone on Plesk is correct, not on php.ini
    Now its fixed, but I'm still unable to apply custom rules on firewall. Now I get this error:

    safeact: execve failed for /opt/psa/admin/sbin/modules//firewall/safeact: Permission denied

    System error 13: Permission denied
    proc_close() failed:


    Now what? T_T
     

    Attached Files:

Loading...