• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

The required version '3.17.22' was not found on the server.

Armis

New Pleskian
i know this is happened already but once again the problem seam to be on the repo so here is what i found...

The update inf3 file request for an autoinstaller file of version 3.17.22
https://autoinstall.plesk.com/PSA_12.0.18/plesk-12.0.18-cos6-x86_64.inf3
<required_autoinstaller version="3.17.22" binary_directory="Parallels_Installer"/>


but in the repo for centos ? X64 there is only a 3.16.20
https://autoinstall.plesk.com/PSA_12.0.18/dist-rpm-CentOS-6-x86_64/opt/updater/

im using plesk 12.018 #52 on CentOS 6.6 X86_64

Thank you.
 
Hello,
Yes, the plesk updater package included in Plesk 12 distribution is 3.16.20. But if executing version of autoinstaller is lower than required then autoinstaller is automatically downloaded from autoinstall.plesk.com (or mirror server) and self restarted. Actual binary of autoinstaller you can locate in /var/cache/parallels_installer/
 
so when this gonna be fixed ?
cos actually the version on the autoinstaller on the repo doesn't match the requirement
i did remove the parallels_installer_CentOS_6_x86_64 and this haven't fix anything
 
well this is what happen when i try to update with plesk
Unable to obtain the latest version of Parallels Installer: The required version '3.17.22' was not found on the server. This could happen because of configuration error at the download site. Version is not specified. Error in Version.cpp, line 91.
 
And what do the following commands show:
Code:
# wget https://autoinstall.plesk.com/Parallels_Installer/parallels_installer_CentOS_6.6_x86_64
# chmod +x parallels_installer_CentOS_6.6_x86_64
# ./parallels_installer_CentOS_6.6_x86_64 -v
Parallels Installer 3.17.22 (built on 2015-05-12 11:37)
 
never mind fixed it
the Linux used is a CIS compliant and the /var for some reason was noexec

Thank you
 
Last edited:
Note that the problem is NOT the /var being noexec but plesk droping executable files in /var/...
this is not acceptable
 
Back
Top