1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

The uploaded file exceeds the upload_max_filesize directive in php.ini.

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by kilerb, May 14, 2012.

  1. kilerb

    kilerb Guest

    0
     
    Hi, this is probably a total newbie question... But I am trying to upload a plugin to my wordpress site. Never had issues before. Now it's saying "The uploaded file exceeds the upload_max_filesize directive in php.ini."
    I called support for my server and they told me I don't have an SSH client installed. He couldn't find my php.ini file for some reason. Is there a pretty easy way to up the size restrictions for this domain or the entire server? The file is less then 6 megabytes...

    Thanks a lot!
    B
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,547
    Likes Received:
    1,240
    Location:
    Novosibirsk, Russia
    By default, PHP limits uploaded files' size to 2 MB. This limit applies to all PHP applications. Edit the following options in the "/etc/php.ini" file on the Plesk server and set the values to match your needs. For example:

    upload_max_filesize = 32M
    post_max_size = 32M

    Restart Apache after the "php.ini" file modification.
     
Loading...