1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Tomcat moule says: Database Error

Discussion in 'Plesk for Linux - 8.x and Older' started by jonasstein, Jul 10, 2005.

  1. jonasstein

    jonasstein Guest

    0
     

    The user uploaded Opencms.war

    He pressed enable and started the application.

    Now the tomcat module says:

    "Actual status of the tomcat web application does not correspond to the
    status described in the database".


    i have found some strange entry in the Database:

    > mysql> select id, name, params_id from domains where name like '%spoerkelhof%';

    returns

    +----+----------------+-----------+
    | id | name | params_id |
    +----+----------------+-----------+
    | 17 | spoerkelhof.de | NULL |
    +----+----------------+-----------+

    I suppose the NULL is one of the Problems.


    Further Tomcat does not deflate the .war File. I suppose Opencms needs to be extracted.

    Please help me. Thanks for reading so far.

     
  2. hardweb

    hardweb Guest

    0
     
    If you delete the application and add it again, do you get the same message?
     
  3. jonasstein

    jonasstein Guest

    0
     

    Yes. I deleted it and uploaded it for several times.

    In the Opencms dokumentation it says opencms.war needs to be extracted.

    But it seems it did not deflate automatic.

    I tried to deflate it manually with unzip, but this did not help.
    Probably i did not move it to the right directory or the directory needs to be entered in the database.

    Did you ever get opencms with plesk running?
     
  4. AplosMedia

    AplosMedia Guest

    0
     
    I actually tried installing magnolia

    It has the same issue, after installing the WAR, it says:

     
  5. jonasstein

    jonasstein Guest

    0
     

    I'm mailing for about a week already.
    One of the coders gave me good hints, but it does not really work with opencms yet.

    As this is an SwSoft Forum and the SwSoft support seems to busy to answer you here, id like to copy an excerpt of these mails.
    I hope that is OK.

    probably you get an idea for a solution.
    And please report me about you effort!

    Finally everything but the database was OK.

    The entry was 'NULL'





    Actually, that message can appear for many reasons. So, I can give you some
    thoughts how to solve that issue:
    1. You should check that tomcat resolves internally, in this case,
    /etc/resolv.conf should contain such line:
    nameserver 127.0.0.1

    2. Status of the tomcat differ from status in PSA database, in this case you
    should check status directly in psa db:
    For example for domain alex.org tomcat is enabled and contain tomcat app. -
    examp2, the information in db should be such:

    #mysql -uadmin -p`cat /etc/psa/.psa.shadow` psa

    mysql> select id, name, params_id from domains where name like '%alex%';
    +----+----------+-----------+
    | id | name | params_id |
    +----+----------+-----------+
    | 6 | alex.org | 19 |
    +----+----------+-----------+

    next, DomainServices table for alex.org id=6:
    mysql> select * from DomainServices where dom_id=6 and type='tomcat';
    +----+--------+--------+--------+---------------+
    | id | dom_id | type | status | parameters_id |
    +----+--------+--------+--------+---------------+
    | 27 | 6 | tomcat | 0 | 27 |
    +----+--------+--------+--------+---------------+

    status=0 - service is enabled.

    next, WebApps table, tomcat application status on alex.org

    mysql> select * from WebApps where domain_service_id=27;
    +----+--------+--------+-------------------+
    | id | name | status | domain_service_id |
    +----+--------+--------+-------------------+
    | 3 | examp2 | 0 | 27 |
    +----+--------+--------+-------------------+

    status=0 - application is enabled.

    Also values of manager_login and manager_passwd in Parameters table must be
    such as in ../tomcat4/psa-users/alex.org.xml file:

    mysql> select * from Parameters where id=27;
    +----+----------------+----------------------------------+
    | id | parameter | value |
    +----+----------------+----------------------------------+
    | 27 | manager_login | 26fc8a1ccf91cb174a22a764de6bbad1 |
    | 27 | manager_passwd | c1ba3448f9ea1fb33529dd3d047bb0a7 |
    +----+----------------+----------------------------------+

    [root@kathy psa-users]# cat alex.org.xml <?xml version="1.0"
    encoding="utf-8"?> <tomcat-users>
    <role rolename="manager"/>
    <user username="26fc8a1ccf91cb174a22a764de6bbad1"
    password="c1ba3448f9ea1fb33529dd3d047bb0a7" roles="manager"/>
    </tomcat-users>

    3. Domain on which tomcat is enabled should be registered.

    4. Make sure that port #9080 is open.

    Our records indicate that you have purchased through one of our resellers.

    As such, they are your first point of contact for support and general
    inquiry. If they can't / won't support you we would like to know this.
    Additionally, we would like to offer you the following options if you wish
    to receive support from SWsoft.

    <> Per incident support - $75

    <> Unlimited 24/7 e-mail support for one year - $299

    <> Premium support - Unlimited e-mail support plus 25 phone instances for
    one year - $549

    * Note: Per incident, Email and Premium support agreements cover issues
    related to PSA. If your support request is found not to be related to PSA
    the work will need to be treated as Technical Services work. SWsoft, Inc.
    Technical Services are billed on an hourly basis and your per incident
    support fee can be applied toward this service.

    SWsoft's Technical Support Team provides years of expertise in system
    administration, application integration, and PSA related tasks to our
    customers. We promise to complete the work in the fastest possible time
    frame in a professional manner and assist you in understanding the work
    being performed on your system.

    SWsoft is now excited to offer our clients 24/7 email support. Order your
    PSA support package today by completing our request form:

    http://www.sw-soft.com/r/upload/sw-plesk-support-purchase-request-form.pdf

    Please fax support request form back to +1-703-991-0550 and update this
    ticket.



    Here how i could fix that
    domain.params_id field deprecated. Please do the following to fix the
    problem:


    Firstly get manager's login and password for the domain:

    mysql -uadmin -p`cat /etc/psa/.psa.shadow ` -D psa -e 'select
    p.parameter,p.value from Parameters p, DomainServices ds, domains d where
    p.id=ds.parameters_id and ds.type="tomcat" and ds.dom_id=d.id and
    d.name="DOMAIN_NAME";'

    +----------------+----------------------------------+
    | parameter | value |
    +----------------+----------------------------------+
    | manager_login | 3030435a3bce1dff91a1a98d6f6be993 | manager_passwd |
    | d59a93a6a8ebd4b90421ff0fe47e76df |
    +----------------+----------------------------------+


    Then use these valuse to create the file.

    export PSA_PASSWORD="d59a93a6a8ebd4b90421ff0fe47e76df"

    ...psa/admin/sbin/tomcatmng --install-service --vhost-name="DOMAIN_NAME"
    --manager-login="3030435a3bce1dff91a1a98d6f6be993"

    Restart tomcat.


    > Somewhere i read tomcat will be accessible on
    > spoerkelhof.de:9080/example and spoerkelhof.de/example in the same
    > way if enable


    You can access standalone tomcat server as spoerkelhof.de:9080/example.
    But if you with to access an application through Apache, you have to add it
    through Plesk or set needed records like:

    <IfModule mod_webapp.c>
    WebAppConnection spoerkelhof_de_conn warp THE_SERVER_IP:9008
    WebAppDeploy "example" spoerkelhof_de_conn "example"
    </IfModule>


    in domain vhost.conf. Then run "psa/admin/websrwmng -a -v".


    Our records indicate that you have purchased through one of our resellers.
    [...]
     
Loading...